Loop subdivision problem


I have ran into problem not being able to wrap loop subdivision fully. For some reason it only subdivides outside. Please take a look at screenshot comparison.


Do you have quad topology all the way around?

Loop cut will stop at Ngons and triangles.

1 Like

Thanks for jumping in :slight_smile: Not sure if I do something wrong but I tried to convert Mesh > Faces > Tris to Quads and the problem still there. How would you approach it ?

I would either use the knife tool to fix the topology or start over since it seems you are till in the early stages.

Looking the image, the problem seems to be at the front left side (from our perspective) of the couch.

You’d be surprised I have made a new piece:) Still the same. This sofa part was also cut in half/ deleted for mirror modifier. I will try cut loops on a new part prior to any cut/deletes . Thanks :slight_smile:

Can’t be that hard.

See attached file.couch.blend (451.2 KB)

Work only has version 2.79 and i haven’t had time to update it here yet so hopefully it opens.

1 Like

I know. Your topology is slightly different and it works fine. Check out my file and let me know if works on your PC.
sofa project.blend (737.9 KB)

You know, your method works a charm. What I have to do is to change a bit topology by using knife tool. I have done both on slightly tilted planes and on perfect 90 degree faces it works just fine.
I am following tutorial in which a person does not do any extra steps that are noticeable to my eye, at least no extra loops. Another learning curve. Many thanks for your help :slight_smile:

Glad it worked out, i also took a look at your file.

There is an Ngon at the front, if you select the vertices i circled and press J it should fix it.

1 Like

Thanks. I have another lesson learnt today! Such small thing that bothered me for almost 2 days!