Lost numberpad communication. How do I get it back?

It didn’t take me long to notice that I couldn’t change my view using the numberpad. Some quick checking also told me that I can’t enter numbers into blender from it at the moment. the numberpad works just fine in microsoft applications. I also tried restarting the PC. Any idea what might be causing my problem? More importantly: Anyone know how to fix it?

Check under File > User Preferences, and click on the Input tab.

Is Emulate Numpad checked? Try turning it off if it’s checked.
Do a search for View numpad. You should see all the various views and more. See if they got accidentally bound to something other then the numpad keys.

If that fails, maybe try downloading a previous version of blender?

Is your numlock key on?

Emulate numpad did not fix it. I did the search you suggested, and it appears that I’m not the first person to have this problem, but no one’s successfully identified what it is. I tried reinstalling, and the problem hasn’t recurred yet. If it happens again, I’ll add to this thread. Thanks for your suggestions.