Lots of little white specks when using Cycels

When exporting a tutorial for rigid body physics, I noticed a lot of little white animated specks.

1920 x 1080 30 FPS
GPU render using GTX 570
Samples 200
100% scale for render
PNG RGB format
124 frames
When viewed at 1080P Full frame specks can be seen and paused over wood platform area.

Have you tried turning filter glossy on? I usually set it to 1. the other way is to use the despeckle node in the compositor

I do all my compositiing in AE. I just export the Cycles animation out as a PNG animation sequence. Havebt seen either of the options you mention in the animation portion of Blender.


Thanks Darkem. I will give it a shot.

UPDATE. The Despeckle Node set to .1 removed all the white specks! The Cycle render is immaculate. Thanks again.