Low FPS rate on playback on PC vs MacBook pro

Hi there!
I get low FPS in viewport playback on a beefy PC, while I get better FPS count on a MacBook Pro that is supposedly to be an inferior machine.

Blender 2.90.1

Pc:
i9- 7940x 3.10 GHz
GeForce RTX 2080Ti
64 Ram
500gb SSD

MacBook Pro:
2.9 6-core intel core i9
16 Ram
Radeon Pro 560x 4 GB (not available for Blender, so I guess this doesn’t play a role)
500 Gb SSD

I am following along this tutorial on liquid simulations .
After baking the data, I get a FPS rate in the viewport of less than 4FPS from frame 1, while the performance of the machine in the video tutorial ranges from 20fps to 8fps. (i can’t tell which specs the machine from the author of the video has, but worth to mention that my PC bakes the data at a noticiable faster speed).
I tested the same file on the MacBook Pro described above, and I got 10 FPS from frame 1, not going below 7.5 FPS throughout the complete playback.

Any clue on what’s happening?
Thanks!

(Note: I am a new user, so the system does not allow me to upload files… But hey! Hello everyone!!)

Radeon Pro 560x 4 GB (not available for Blender, so I guess this doesn’t play a role)

Can’t help you with your problem, but your GPU does help a lot on the MacBook with the viewport and Eevee; only for Cycles rendering it is useless.

2 Likes

Yes, true… But still, that Mac GPU can’t match the performance of the RTX 2080ti… Thx @blenderrocket!

I think I found the issue. This PC that I am working with has a SATA SSD, which appears to be too slow when it comes to read the cached data of the simulation. A friend of mine tested it both his PC and his MacMini:

  • PC started at 11 and ended at 8
  • The MacMini started at 22 and ended at 15 !!!

Some data on the machines of my friend:

  • Pc: cpu has 14 cores, 28 threads / 128 GB Ram / PCI HD
  • MacMini: 3.2 6-core i7 / 64Gb ram

Still the difference is too big in favor of the MacMini. But… why?

(maybe this thread is now deviating from Prticles and Physics Simulations… If an admin wants to move it to somewher more appropiate, I will be, of course, fine with it :slight_smile: )

I installed a Samsung Evo 960 NVMe.
It only improved by 2 fps…

No clue what is making this machine to read the baked data that slow…

Some motherboards default to using the on-board GPU, instead of a third party card. Perhaps your PC is presenting the GPU on the i9, instead of the nVidia card? (check the bios settings)

Try monitoring your GPU usage while conducting the test…?

Curious, what MacMINI has 64gb? They were only rated for 32 from the factory…

BlockquoteCurious, what MacMINI has 64gb? They were only rated for 32 from the factory…
Current MacMini can be configured from the factory up to 67gb (well, you can save quite a lot by doing it yourself :slight_smile: )

I will try to do what you said. I can’t yet upload any files to the forum, so I can not show you the file, but I thought that, when it comes to playback the baked data, the GPU does not play much of a role…

This thing is driving me nuts… luckily this is one of my companie’s workstations, so I can suffer this inconvenience while I try to fix it with less pain as if I would have payed for the machine…

I used Task Manager to monitor the activity when I playback the simulation:

  • There is an increase from 2% to 10% on CPU usage
  • There is an increase from 1% to 10% on GPU usage
  • There is no increase at all on any of the SSDs (which seems strange, since it is supposed that Blender should be reading the baked data from the disk… shouldn’t it?)
    These look to me as pretty low numbers. It seems that there is a lot of potential not used…

I have faced the same problem with one of my animations. I thought it was my scene, and my PC is similar high end as yours. But I thought that slow FPS were because of the scene complexity… What I did notice, is that when COLLISIONS are turned on, that was when everything would dramatically slow down. So my question is, do you have colliders in your scene? I am curious because indeed it sometimes rather seems that in very specific occasions PC potential is not used.

Hi @JOYASROHRBACH!
The problem is that this same file is performing better in machines with lower specs. So I don’t thik it is dependant on the settings of the scene.
The scene (since I can’t still upload files to the forum) is exactly as it is described in the tutorial linked above.
I have colissions enabled for the fluid domain.
The particle count at frame 10 (5 Fps) is 13.536.
The particle count at frame 150 (4,38Fps) 112.310

Thanks!

After several re-installs, i did a clean instal by removing absolutely everything that I could find. Finally, Blender opened up without any of my settings, but this did not help. Outcome is the same. :confused:

Those SSDs in moden Macs are insanely fast.

Sure! but still my FPS count is too low… I may not be able to achieve same numbers that a mac with a SSD soldered to the motherboard, but this guy should be able to do better as it is currently doing.

I don’t see myself progressing much on particle simulations with this limiitations.

As I said, this is not my computer. But I am using it to asses the specs should I aim for when I will buy my own one. This issue is giving me the creeps - expending such an amount to find this apparently unsolvable bottleneck… buf…

I also have the same problem on a new PC, my old PC is almost 10 years old excluding the GPU and it runs playback faster than my new PC.

I am guessing that it is coming down to Blender not utilizing the hardware correctly so most likely some compatibility issues. Maybe we can come in contact with a dev to run some tests.

Hey @GrimZA! Good / bad news to hear about someone with the same problem…
I am about to make a clean Windows installation on a partition and start from scratch.
The IT guys at my company were not able to spot the issue. Same thing: they executed the file in their computers and got way better FPS on weaker machines.
So what you are suggesting makes a lot of sense to me: a compatibility issue.
I will come back with the results of my test and then we can see if we should report a bug.
Thansk!

Installing Blender in Windows 10 Pro instead of Windows 10 Enterprise solved the problem.

I get similarFPS as my friend ( between 9 and 11 Fps). I think this is still not much for these machines, particularly if we compare them with the outstanding performance of the macs.

So the reason for the low FPS count may be on the Windows version (Enterprise vs Pro), or on the stuff that my company puts into their computers.

@GrimZA Does this help you with your problem?