Make a smooth surface using extrude

I am following a tutorial from Youtube on creating a coffee mug. In the video, he extrudes the surface to start making the handle of the mug and it is a smooth extrude. For some reason, when I try to extrude mine just does a box and it is not smooth at all. Did I accidentally hit a button that switches it from smooth to not smooth? Heres the image I am working with.

Sorry if this is a basic question. This is my first tutorial and I could not find the solution online myself. Any help is appreciated!

Without a link to the video it’s tough to tell, but my guess is that the mug in the video has a subdivision surface modifier added.

Maybe just missing the part where he explain :

  • add the “subsurface subdivision” modifier.
  • Enable “smooth” in tools panel ( left panel of the viewport in object mode ).

I can imagine this is this tutorial ? … look at 15min25s -15min30s

  1. selected faces
  2. inset (i)
  3. looptools addon: circle, alternatively to sphere (alt+shift+S, 1, enter) for each, without middle vertex selected
  4. circle added in edit mode as a profile in the middle, 8 vertices,
  5. all 3 circles selected (with faces), W -> bridge edge loops
  6. with that there’s a face loop around each end so you can add a loop cut (ctrl+R) and tighten the connection if you want
  7. and can control the sides of the handle much better
  8. to make it a bit wider and/or thinner for example.

Edit: did another one and recorded the screen, might be clearer to see what should happen in 3-5

Making the handle starts at 0:29

From the myriad of tools I’m using there, one that can be useful for you at this point is the proportional editing tool. I’m using it in connected mode to shape the handle a bit. Tool controls are on the header, hotkey toggles are: o for on/off and alt+o for connected/off, scroll wheel to adjust the influence area. With that enabled, it’s possible to select something and move/rotate/scale and unselected will follow proportionally.

Thanks for the answers guys! I will give this a shot later tonight. Yeah that is the correct video I am watching. I wasn’t sure if I could post a link with it being my 1st post. I’ll let you know if this fixes my issue. Im sure it is user error since Im an extreme newbie with Blender.

Thanks for the video! That coffee mug is pretty sweet, ill watch it a couple times to catch those shortcuts keys