Make object visible only when intersecting another object

(See my 2nd post for the solution)

I know about the Boolean modifier, but that doesn’t seem to suit my purposes. If you look at my attached image, you’ll see that Blender goes crazy and makes random faces visible. This happens regardless of whether I give the Boolean modifier to the cube or the cape, and regardless of whether I do Intersect, Difference, or Union. It also happens regardless of what I make the cube’s resolution; I get giant triangles if I have just a plain cube.
I’ve also noticed that I lose all my materials when using the boolean modifier.

Now, I want to be able to define an area (or domain, if you will) where I want certain objects to be visible. I was hoping I could do this with the Boolean modifier, but it keeps showing my domain object as glitched faces. The domain should be invisible, and my specified objects should be visible only within it.

Basically I want to do a spell effect which involves lines/bars shooting up from the ground, and they have to only be visible within a certain interval. They only need one material each, so the material thing isn’t an issue if I can get Booleans to work right.
However, I’d really prefer to be able to make the bars particles, so I hope there’s a way to make that work out.

I don’t want to mask or crop them out; it has to look like they disappeared after passing an invisible line - and it has to look like that from all angles.

Now, I was thinking I could use a special Object-mapped Blend texture which controls the alpha, making them visible only within a given interval, but I wanted to know if there was a better solution.


Okay, I’ve decided to go with a Blend texture, mapped to an Empty. I set the Blend to have four color points: two fully transparent black, and two fully opaque. It goes Opaque-Transparent-Transparent-Opaque, where the Opaques are at the edges of the blend, and the Transparents are almost at the edges, so it basically looks fully transparent. I gave my objects’ material the Blend texture, mapped to the Empty, and set to effect only Alpha, with its blend mode set to Subtract.

Now, after setting my Empty to cube visualization, and rotating it 90 degrees Y, the objects with the texture are only visible within the upper and lower bounds of the cube, which is exactly what I wanted.

I just thought I’d explain that so any Googlers and forumers who stumble upon this topic can benefit from my little solution :stuck_out_tongue:

You could also realise this effect with a layered lighting setup.

i.e. Illuminate the particles, or bars, with a narrow shaft of light.


Is there any way to prevent the lightless sections of particles from being visible, besides compositing? If I’m not mistaken, what you described would leave the unlit parts black.

Anyways, as I prefer to conserve my usage of layers (yes, somehow 20 layers isn’t enough for me :p), I think I’ll stick with my method.