making a beer glass

Hey, I tried making a glass of beer, but it didn’t turn out that well.
The objects in my scene are these:
-Glass (has a white material with a lot of transparency and a little bit of mirror)
-Beer which is inside the glass (has a yellow material with also a lot of transparency and a little bit of mirror)
-Cream, foam (I’m not English and I don’t really know what word to use for it, but I think you know what I mean) (has a white material).

But when I render this I get:
http://img227.imageshack.us/img227/7014/testrender.png
As you can see, that doesn’t really look like a glass of beer.
I think the problem is that the light isn’t able to reach the beer inside of the glass, but I’m nog sure.
How can I solve this?

Looks like you need to up the levels on the transparency of both the glass and beer. One level for every face the transparency has to show through. So, maybe 6 for the glass and 4 for the beer. Also, you probably don’t need any mirror on the beer itself since the glass should take care of that for you. That too might be causing the problems you see.

which texture have you used for foam?

Tried what you told me, set the dept of transparency for glass to 6 and for beer to 4 (it was allready set to four for both). Also removed the mirror of the beer. But it’s not right yet:
http://img442.imageshack.us/img442/3490/testrender2.png
Actually everything looks fine, except for the fact that my beer isn’t yellow.(which is of course quite improtant :p)

I just used a white material with a clouds texture.

Did you check the normals?

http://dave.bloopdiary.com/tutorials/beerinaglass.htm

The normals are all outside, still nothing changed.
But I did try this. I’ve made new file and imported only the glass and the beer.
When I now render I get this, which is allready better:
http://img100.imageshack.us/img100/2176/testrender3.png
Now the question is, what’s the diffrence with my original file? I think it has something to do with the world settings.
Any idea?

Ok, I found it, apperently it doesn’t work if you put on the ambient occlusion. Why? I have no idea, but for now I’m just going to leave it like this. Another problem I seem to find is that when I try to render the entire scene, it gets stuck at part 9 of 64 which leaves me an image like this:
http://img404.imageshack.us/img404/6695/foodtotal.png
Anyone an idea why this happens?