Making Blender 2.8 Default for .blend files Windows 10

I have blender 2.79 installed on my Windows 10 (build 1803) machine. I downloaded 2.8 beta and love it so far. I just noticed though that I cannot associate my .blend files to default to opening with 2.8 in windows 10 (windows 10 build 1803) apparently the new win default app setting menu removed the option of manually searching for an app on my computer to set as the default app – the only option Microsoft gives is to “search the app store” – which is an obvious dead end.

This article gives overview of this new problem MS created.

I have not installed the 3rd party app the article suggested to hack it to work and just noticed something else. If I right click on a blend file in Windows explorer, and select “open with” it does give me the option of searching my computer for the app I want to open the file with. I select the Blender 2.8 exe file but even after that, it still only opens it in 2.79?!

The only way I can get a 2.8 blend file to open is to launch 2.8 and then open it through the 2.8 application interface.

I realize the issues are probably because 2.8 is still beta and doesn’t have an installer, but curious if this is how everyone else (on Windows 10 1803) opens a saved file with 2.8?

Normally I wouldn’t mind starting 2.8 then opening my files through the app while I waited for a stable release of 2.8 with an installer, but the main reason I am learning blender is to make use of Verge3d plugin which opens up an easy way to add 3d content websites. (Verge3d is basically the successor of Blend4web)

Verge3d has been upgraded to run with 2.8 but the ‘app manager’ of the plugin (at least on my system) apparently uses whatever the systems default app for blender, which in my case, is 2.79. This disrupts my workflow.

I have posted this over on the Verge3d forum


but since this pertains to blender 2.8 + windows 10 in general, I wanted to poll the community here for possible solutions/work arounds.

Thanks

Is this on Windows 10 Home or Pro? Not sure if it matters, but anyway…

See the illustration below

  • Right-click any .blend file
  • Open with…
  • in the dialog click More apps,
  • use your mouse’s scrollwheel to get the list moving (it won’t look like it’ll move at first, but it will)
  • click on Look for another app on this PC, and
  • you’ll get a file dialog.

Go find your downloaded version of 2.8 and budda-bing, budda-bang, budda-boom.

you gotta keep in mind that you will probably need to do everytime you download new 2.8 build

I went to my Blender 2.8 folder, opened PowerShell and did “./blender -r”. Worked for me perfectly. Blend files even show proper thumbnails in Windows Explorer.
I guess you could just do it from “Run” menu too. Win+R, browse to your 2.8 blender.exe, add the " -r" and run

3 Likes

Thanks Sackadoo but that is exactly what i was doing. It would open in 2.79 despite me pointing it to 2.8 with “open with” item.

Think there was some blender preference file somewhere in my system overriding my request and pointing everything back to 2.79.

I ended up uninstalling 2.79 and then following the procedure you mapped out above and everything is working now as it should. I will be sure to uodate the ‘open with’ association when i download a new 2.8 build. Thanks all for the help!

1 Like

Tried that numerous times. It doesn’t work.

The Windows version of Blender provides flags that you can run for this.

-R
        Register blend-file extension, then exit (Windows only).
-r
        Silently register blend-file extension, then exit (Windows only).