Making Clean Hair Particles

I’m finding it difficult to make these hair particles do what I want. I’m using a density map to stop hair from emitting in the desired area, yet still it decides to emit a few sporadically and the edge between the two areas is really horrible. I’ve tried boosting the amount of particles but it doesn’t appear to really help. I could use some pointers. Thanks in advance.


try to add hair to specific vertex groups and let the middle square out of both. on the hair emission, there’s a setting to change to have a more even distribuition.

on the child settings, see this one:
RoundnessThe roundness of the children around their parents. Either in a sphere (1.0) or in-plane (0.0).

Use vertex groups, and make some really tight loop cuts right at the boundary. Hairs spill into the adjacent faces, so the hack is to make those faces tiny.