Making particles move with an object.

Hey there.

So i’ve been having an issue with a pretty basic particle system that I can’t for the life of me figure out how to make work and was hoping I could get some help here.

Essentially I am trying to make a basic particle system (nothing fancy just a Newtonian system that emits object particles) that moves with the object it’s parented to. As the object that the particle system emits off of is parented to a moving object (a necessary part of the animation) it creates a trail effect as seen with the yellow particles coming off the selected object in this image I don’t want this - I simply want the entire particle system to move in relation to the parented object.

The intention is to have the spheres’ particle system move relative to the ship in the animation so it doesn’t create the trailing that comes into effect because the object is moving, however I still want to be using Newtonian physics for this so just setting it to “none” won’t work (I also need to know how to do this as it’s been stumping me in quite a few animations). The ship is just on a basic key-framed animation rather than a motion path as it doesn’t need any fancy movement in this case it’s just meant to be a straight flyby.

TL;DR I just want the entire particle system to move relative to the object and not trail. Is there a way to accomplish this and if so I would very much appreciate the help as this has been stumping me forever, i’m quite new to particles.


make sure the particle modfier is on the top of the stack list

I tried setting up a simple emitter using Newtonian physics and turning off gravity. I left all the other default settings the way they were. When I run it the emitter leaves a small trail as it moves across the screen. Turning up the number of particles to 3000 thickens the cloud of particles around the emitter, and turning down their lifetime to 5 causes the trail to lessen significantly, to the point that the particles look more like flickering flames being blown back as the emitter moves forward, but not leaving it. Cranking the count up to 10,000 looks even better, with no significant trail.

Switching the emitter to emit boids or fluid and playing with the settings doesn’t appear to help.

Apparently, particles are affected by the motion of the emitter, with or without gravity. That means that you’re basically stuck with getting a trail unless you keep the lifetimes short enough that they die off before they trail too far.

If the movement is in a straight line you could add an emitter object velocity (X if it is travelling along the X-axis) in addition to the normal velocity.
particleMove.blend (2.98 MB)

You just have to create particle system simulation that you want without object movement and bake it.
Then, when particles are baked, you can have bake simulation following parent object by precising it in Render Panel of Particles Tab.

But, if you want particles using Newtonian physics and colliding during parent movement, you can not avoid a trail effect.
Object slider makes the particle initial velocity relative to object velocity at emission frame.
But object velocity is modified by animation. So emitted particles have different velocities because they are not emitted at same time.
It results in a trail that is coherent with Newtonian physics.
For that, you will have to cheat.

If you need just one particle system, leave the emitter stationary, and parent the rest of the scene to the camera. Then move the camera in the opposite motion, and the emitter and particles will appear to be moving together.

1 Like

I am just trying to solve this myself. I have a tree swaying in the wind and i want the fruits in the tree that have not fallen yet to sway with the tree thus looking like they are attached to the tree until the moment they fall. However, i found that the Newtonian physics that allow the fruits to fall also make the fruits that are still attached NOT sway with the tree (when the tree sways it was leaving fruits cloud in the shape of the tree behind, floating in mid air!)

I have partially solved it by alt-d the emitter and then grouping it in a group of only itself. Then use an empty to dupli group it. You can rotate and move the dupligroup with all the particles rotating with it.

For a smaller number of items, like fruit, you can use physics for the falling part, bake the physics, and then use a copy loc-rot constraint to have it follow the tree.

Hey Zeauro, wht you describe in your first paragraph is exactly what I’m trying to do.
However I can’ find anything in the Render Panel of Particles tab that makes this happen in Blender 2.91.
Did the menus change since 2017 and if so is there still a way to do it in the latest Blender ?
Thanks this would be a super powerful technique for stylized particle animations !

The feature was renamed Coordinate System.
It is only displayed for Halo Particles type.
But anyways, 2.8 refactor broke the feature. It does not work, anymore.

The good news is that the initial goal of this thread (particles following animation of parent) is supposed to be supported, now, without problem.
So, normally, you should be able to bake with animation enabled and obtain a pertinent result.

Thanks for that reply !
Can you go more in detail as to how one parents a particle system to an object ?
Also where do you enable animation for a particle bake ?

What I meant is that animation of parent of Emitter object is supported, now.

In other words, you don’t have to think anymore to what you do.
If you have emitter of particles as child of an animated object (parented using Ctrl P shortcut or drag and drop in outliner), just do animation of parent object before baking cache of particles.

And if you want multiple instances of a particle system ; just put emitter of particles into a collection, use a collection instance and render particles as objects.

The feature is broken but it is no more useful in most of cases.


My current scene is a little too complex for that to be practical.
I have a vehicle racing across the world and a camera tracking relatively, plus I am cutting between multiple cameras.
I’ll keep looking for something more to the point.