Mandrake linux problem - no root access from boot splash

I just installed Mandrake 9.1 and everything went well except I cannot log in as root. On the login screen is only the user account for me. Root doesn’t show up. There is no place to type it in either. I need to be able to log in as root. Any idea how to access the root login? I can access some root functions by typing in the root password when I open a configuration program. Some won’t let me do that.

Any Ideas?

I got around this problem by using text mode login instead of the graphical. But I would still like to know how to add the root option to the graphical login screen.

not sure i understand your problem :-?

you can set kde (for example) to log in as the user you choose in which case you will go straight to the gui ,

or you can set it to wait

at the log in for an id and a password

typically you would have to open a shell and su to change to root



Try using “CTRL + ALT then F1” to change to a different screen (text console) ,then log in as root, if you need a graphical interface type start X, after you log-in. Going back to the graphical log-in screen should be “CTRL + ALT then F7”
This works on all of the linux (X11) systems I have.

Grizzly, you may not see the root icon, on the gui login screen, but that doesn’t mean that you can’t login as root from there…

It’s just that your login screen is set up not to show an icon for the root account, by default…

You can still type in there “manually”: “root” as the user name and the root password at the apropriate fields and VOILA!!!

If you want the login screen to show a “root” icon, at KDE go to:

Preferences>System>Login Manager

it will prompt you fro the root password… type it and the program will start… Then go to the users TAB…

There you have the option to add or remove, the users that you want their icon to show at the login screen…

Remove root from the “no-show users” table and your problem is solved…

I hope it helps…

Nice to see you again Grizzly69… :smiley:


I would type it in manually, but mandrake 9.1 Login GUI doesn’t have where you can type in anything but a password. In previous releases there was the spot to manually type in the user and password, but now you can only select an icon then it lets you put in a password. Its odd. I will try the Ctrl, Alt f1 deal.

I went looking thru all the configuration stuff and couldn’t find any way to add root to the login GUI. But the text login works just fine.

Thanks for the responses.

Just a note:
X11 normaly uses screen Ctrl Alt f7, that leaves f1-6 for other log-ins, so you can actually have 7 sessions open at the same time.

Okay, Thanks to all your help fellow Elysiunians.

I found the Login manager like Timonides said and fixed the problem.
I remember trying to use login manager under my regular account, but It wouldn’t even let me enter the root password. It said I had to be logged in as root. I did not try opening a terminal and logging in that way at the time. But still, the problem is solved.

Thanks again for the quick response and helpful answers.


O.k. that’s good news Grizzly69!!! :smiley:

I’m glad that I have been helpful…

Ohhh… and try to remember… We do not login as root unless there is a good reason for that… :wink:

Try to get used to the su command instead…

It’s a very healthy habbit… :wink: