Manually adding a vertex group to a bone's weight map

Hi guys I’ve been muddling around with rigging today and I’ve run into a problem that has me stumped.

I’ve accidentally deleted a vertex group (using the [-] button, image 1). I’ve attempted to replace this vertex group using the [+] button shown, renaming the group, then mapping it to the relevant faces using the [assign] buttons and double-checking they’re attributed to the correct faces using the [show] button.

For some reason I can’t seem to link this vertex group to my weight map and restore influence to this bone. Attaching the blend if it’s any help… can’t work out where I’m going wrong for the life of me ;-p


Human_ProportionRef_v02.blend (1.18 MB)

Your Leg_Upper_R bone has an extra underscore in the name (Leg_Upper__R).

Edit: I like using dots instead… easier to type and easier on the eyes (Leg.Upper.R) :slight_smile:


Looks like you used edited Rigify rig. That’s ok, but rig may not be clean.

Thanks for having a look, guys. Afraid no dice. Rig is home-made, spelling on vertex groups names hasn’t altered anything, weight mapping triple-checked. Afraid that I still can’t restore influence to that bone!

Not a biggie- this is a tiny rig- will delete the vertex groups, re-parent and start again!

Worked for me earlier when I changed bone name to match vertex group name Leg_Upper_R. Worked this time when I changed vertex group name to Leg_Upper__R. (see attachment)

Not a biggie no. Just sayin’ it worked for me instantly after renaming one or the other. Easy fix here. You haven’t gotten to the real brain-busting rigging issues yet. Evil laugh:slight_smile:


Human_ProportionRef_v02-LP.blend (1.18 MB)

Thanks Larry- Had just worked that out after a little independent testing. How annoying! Thanks for your help- going to hit some of the training videos, methinks!