Map model doesn't preview correctly

Low Poly Map

Blender Community,
I purchased this file online. It is originally a .c4d file render ready. I had to import and reassign the color maps. I’m a Blender novice and I’m not sure why the eevee preview is rendering this way (triangles flickering while changing the view) but it looks “good” from top and side angles. Does anyone know why it changes while rotating the view? I also think possibly some faces are inverted.

Thanks for any insights!

I think you have overlapping geometry.

If it’s a single mesh, go to edit mode pressing the tab key, and select all (at default it mesh is already selected)

And press M > Select by distance … see if it removes any overlapping vertices.

maybe its something different- hard to tell

1 Like

Thank you for that! It worked on the water. So now all the other geometry has this glitch still. I’ve done the same procedure on the individual shapes and it doesn’t seem to help. I’ve also tried flipping the normals, backface culling on/off, checking the transparency. I’m not sure what I’m missing. The whale appears to be transparent in front of other objects. If I can figure out why this is happening, I can apply it to the rest.

oops, what happened to the islands on the map? seems like they also got deleted.

I think the best thing to do is select only the ocean mesh and do the merge. that way it would preserve the rest of the parts as it should.

in Edit mode > deselect all > Hover over one part of the island and press L…

It should select only the connected meshes of the surface…

Then move selected pressing G. See if it isolates the mesh.

Yeah, I’m going to start over (I didn’t save over the work). Very puzzling but I’ll try and see if it helps. I’ll also upload it here Low Poly Map Files

Feel free to take a look at the source files. Thank you.

Ahh… I forgot to mention that when ur model covers a large area - the camera clipping needs to be adjusted

So u can easily fix this by pressing N > go to View > Clip start to about 1 or more.

And also… I see a little bug in your blender file…

So u can select all- and copy paste into a new blend file…

1 Like

I agree that this is an issue with overlapping geometry, but I wouldn’t merge the geometry to fix it. Merging it would make sense if you made this yourself and didn’t intend for anything to overlap, but this was probably an intentional choice made by the modeler (maybe it was only meant to be viewed from the top).

Anyway, my guess is that the land and water are meant to be separate geometry that is supposed to clip through each other in certain spots. The issue comes from geometry along the sides occupying close to the exact same spot. The render engine doesn’t know which of those two to render in front, so you get that flickering. It is called z-fighting. I would just move the over lapping geometry slightly, so that they don’t occupy the same space.

I am going to assume that the geometry is all inside one object. and that you are using the default keymap. Select the object and go into edit mode, select one vertex along the side where the issue occurs, then press ctrl + L. This command selects all the geometry that is connected to that vertex, so it should select the entire portion of geometry that is overlapping with what it’s z-fighting with. Now press S and type 1.001 then press enter. This should slightly scale that geometry away from the other geometry and keep them from being too close together. If the geometry is in multiple objects, then I’d select one of them in object mode and do the same.

1 Like

Copy/paste fixed everything! Wow. How did you know there was a bug? That’s amazing that’s all it was. And the camera clipping is an issue but that setting also helped show the geometry fully. Thank you!

1 Like

Z-Fighting…I always wondered what that was called. Thank you. It looks as though the issue was a bug? Not sure what bug but a simple copy/paste fixed it.

I’m glad it worked! I noticed that I couldn’t select anything at first. and then checked in the outliner it had a lot fewer objects listed.

Maybe its a bug… but I really don’t know the cause/ or how to reproduce it to call it as one :sweat_smile:

1 Like