Mapping Texture to "folded" model


(Abavagada) #1

I am trying to make a flag on a ship. I made a simple image of the flag, flat, then made a model of a flag, as it might be hanging… folding and drooping a little. When I add the texture [the flag image] to the flag model, they don’t match up, obviously. I have tried several adjustments, and can’t get the image to map like it would to the flag. I have tried some settings in the UV editor, from what I can understand from the tutorial, but still, I am lost. Any ideas? Is this something easy or near impossible?

Thanks


(kos) #2

why not map the texture first then fold the flag like it were hanging?it is easy like drinking water…as far i think i understood your problem.


(Abavagada) #3

Just tried that.
If you know how a flag droops, then you know the sides remain straight while the tops and bottoms go down. This causes the whole design to lean as well. Once I apply the texture, then shift the other vertices [the base ones don’t change, since they are what is attached to the pole], the image doesn’t tilt… just the flag.

Maybe I should be asking how to make the image tilt?


(blenderanim) #4

Try changing the texture mapping to Object. I think the default is Orco.


(IamInnocent) #5

First subdivide a mesh plane enough to get the smooth folding you are after.
Scale it to the proportions of your image. I had one of 311X150 pixel so I made my plan x=3.11 and y=1.5 with the NKEY.
Next give some uv coordinates to your plane by passing to the faceselect mode FKEY and by choosing “from window” as a mean of projection under UKEY.
Last, image map you flag, using the UV projection mode instead of the default Orco.

Good luck.


(kos) #6

write a py script for softbody animation or hunt for maya :wink:


(Abavagada) #7

After the advice and a few more tries, I got my flags flying correctly! Thanks for everyone’s help.

The last problem I had was once I loaded the image, it was too big for the plane, even tho I had defined the plane to be the size of the image. Even if I enlarged the plane, the image grew too, so was still larger. Finally, I adjusted the x and y for the image loaded (actually, a little less), and it worked perfectly!