Material: cooked pasta (help)


(dinne7) #1

Hi, I’m trying to make these spaghetti (please ignore the draft of the “sauce” ;p)
I am not that expert in making materials, so I’m asking some advices…
Mainly I’ve tried with the Subsurface Scatternig and with the Translucency, but the results aren’t the ones that I want.

Here my attempts:

• This one is made with Diffuse + Traslucency nodes with the same color applied, but I can’t obtain a brighter result (unless I drag the Fac more on the Diffuse side, but in that case I would loose, of course, the effect in question)

• This one is made with Subsurface Scattering (the intensity is 0.200) with the same color of the nodes mentioned above, and a somewhat similar color is reproduced also in the Radius values but I get some glowing areas that seem like almost emissive, you can see them in bright yellow, for example between 2 colliding spaghetti etc).

I think that the Subsurface Scattering mode is not my solution, because I don’t want those random glowing areas so bright (maybe that this shader works better in presence of a bigger and more regular volume? Idk). Translucency instead is not bright enough…
So what should I try to do?


(burnin) #2

First, make it known, how those spaghetti in your graph looks like :wink:


(dinne7) #3

Oh it’s very very very basic…

Now I’ve put 0.100 in the Subsurface and set ni the Radius the exact same color selected in the palette…
So now it’s even more visible those thing of the glowing areas where the spaghetti collide


(zanzio) #4

Have you tried this same setup in the master build(2.79.6)? This could be some sort of glitch with subsurface scattering.


(Para) #5

Howdy there Dinne,

Why aren’t you using the Principled shader? It was designed for these materials. But regardless, did you try lowering the radius size? That should turn down the subsurf effect.

P.S. I kind of prefer the more yellowish look of the spaghetti in your second image better than your newest one.


(dinne7) #6

In the end, I’ve discovered an interesting thing.
For some reasons, that’s probably not a bug I guess (I don’t know), the SSS “enlights” the intersections of the meshes and the very close points as seen in the previous images, but if the meshes are all separated objects it doesn’t happen.
Here a proof as documentation:

So I guess that my solution here is just to… Separate all the meshes of the spaghetti, into separated objects. :slight_smile: I’ve tried so many other solutions by changing the values in so many combinations, both with the nodes manually and with the Principled shader, but… Nothing. So I’ll try like this now. :slight_smile:


(zanzio) #7

Did you try the master build? I ask because a while back there were some issues with the old compiler they used for the windows builds. People had weird issues with different shaders. I think one of the issues was related to the subsurface scattering shader.


(dinne7) #8

Hey no I haven’t (yet), because I have read that it could give instabilities etc. But I will, because actually I want to have it as singular main object and not many spaghetti separately. :slight_smile: so if there is a chance, I try. Now I just try to see the result by separating them… And I’ll try the master build.


(SterlingRoth) #9

If you try the master build, try the random walk option instead of the christensen-burley mode. It should produce less light areas.


(zanzio) #10

Even though it says it isn’t as stable, the version built on 2.79 is fairly stable. A lot of people are using it instead of 2.79b because it has features we won’t see until 2.8 is out.

If you want to keep the two builds on your system at the same time, you can add a folder named “config” under the 2.79 folder to make blender save all the user settings you change to the config folder.


(dinne7) #11

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)