Material does not receive sunlight - 2.83 evee

I have a simple experimental scene with 2 planes, a sphere, and the sun. I created the material for the first (larger) plane and created a group node. Then I created the second (smaller) plane and applied the same material to it.

But the second plane is not illuminated by the sun - it does not “see” the sun at all. I also tried simply duplicating the first plane and that works.

I also eliminated the material from the first plane and re-applied it. That worked, so the node group is fine.

So there must be a difference between the planes, but I can’t find it. I want to be able to append this node group to other objects, but it only works for this one plane or its clones.

I cannot find a reason for this. Attached is a JPG so you can see it and also the Blend file. Thanks for any clues.

ROUGH GROUND.blend (1.9 MB)

Your upper plane is upside down. If you are new to 3D it may not be logical, but the back faces of a mesh do not catch the light the same way as the front faces. Flip your upper mesh to fix it.

PS - turn on Face Orientation in your Overlay panel to see which way the mesh faces.


Thank you very much wacampbell. That worked perfectly. And the face Orientation check will be useful.
It’s a mystery though why Blender creates a new plane that is upside down. Why not right side up?

But I never complain about Blender developers. They move in mysterious ways, their wonders to achieve.

I am glad that helps. Of course when Blender creates a new plane, it is ‘right side up’. This is not a developer problem. I don’t know where your sample scene came from but it has more problems than what I described. I was just trying to keep my explanation simple. To allow you to dig more into the truth, I’ll add that its your bottom plane that’s up side down. But there is also a problem in your shader that is inverting the normals. So two wrongs on the bottom plane make it appear right.

OK, thanks again. I’ll rebuild the node tree from scratch and see if I can make it work right on a newly-created plane.

Final solution: normal map should not be plugged into “normal” on procedural shader, but rather into “displace” on the Material Output. All problems then disappeared.