Material & texture preview windows shown black

Hi all, we’re making a mod for a game for which we want to render a new main menu video showing a seamless flag animation. As I’m still learning Blender, we asked another person to create this animation. He sent the Blender file to us so I could render it. (The game is a bit weird when it comes to videos and we don’t want to bother the other person with permanent re-renderings. Also the texture may change in future.) The problem is that the materials and textures are not shown. I’m not meaning that the flag is black in render mode. Even the material and the texture previews don’t show anything, even no background. This problems still occurs when creating new materials, new objects with new materials or when opened by other users of our team. With other files, my Blender works correctly. I’ve attached an image to show the problem. You can see there that the texture itself is actually loaded but not shown in either the preview or the viewport. Neither the creator of this file nor Google know an answer (or I am just bad at googling). Thank you for your help.

Link to zip file (bigger than the allowed 15 MB):
link deleted


Pink colour = missing texture.

Are the textures in the location as specified ?

Correct the location or manually reload them.

You can pack / unpack / report missing files etc in the File / External Data menu
For example your blend file does not have the texture files packed in them so we just see pink

Unbelievable that I didn’t see this error message (“Can’t Load Image”) until your post. The (cached?) thumbnails tricked me into thinking that the textures were included in the file (hence the file size). I have not fully solved the problem as the preview windows and new objects are still displayed as black but since those are not needed for the animation, I regard this problem as solved.
I also get an idea now why render farms exist. :eek:

Hello, I have the same issue.

I download Blender on Mac, folowing the official tutorials,

using factory defaults settings, the video shows a shaded white sphere on a checker on the Material Preview window for the standard cube element selected, and on my computer I see nothing but black on the Material Preview window.

This is my computer hardware :

macOS High Sierra
v 10.13.6

iMac (27-inch, mid 2011)
Processor 3,1 GHz Intel Core i5
Memory 20 Go 1333 MHz DDR3
Graphic AMD Radeon HD 6970M 1024 Mo

Thanks in advance, I think it’s a hardware issue maybe, but I also think that you have a solution for this somewhere.

Have had the exact same problem. I’ve got an iMac of the same era, but with different spec. If you switch render engine to cycles it fixes it. You can still render with eevee, but it is handy to be able to see texture previews in the texture panel.