Materialiq: material library for Blender

Hi there Blenderheads! :slight_smile:

wanted to share with you what I’ve been working on for the last 9 months - a material library for Blender:)

There came a day sometime in March when I just couldn’t create another new material that’s always different from the last, gets lost in the file never to be used again… and I wanted to create something universal and consistent that I could reuse easily and alter to current needs.

The scope of the project kind of spiraled out of control and I did so much more than I planned…

You can see the website here:

And you can check the BlenderMarket product page here:

Some imagery:

Can’t wait to hear your thoughts on this and see people use it in their projects. I am certain it will be very helpful.

Thanks for reading, blend on and please do let me know your thoughts and don’t be afraid to ask questions!



It looks great! :slight_smile: Are the materials done proceduraly?

Looks like the library is very high quality. The stones are particularly beautiful…

Thank you!:slight_smile:

The materials use bitmap textures in either 2048x2048 px or 4096x4096 px resolutions depending on the pack.

However the way the textures come together is procedural in the sense that there are many Nodes and NodeGroups that combine them and generate other maps from the Diffuse Texture for example.

So the materials themselves are much more than just textures plugged into PrincipledBSDF, there is an entire system that everything is built around.

Thank you :slight_smile: There were many many hours put into it.

The stones were especially hard because their normal maps are very important so generating them correctly took lots of effort.

Hi blenderheads,

A while back we’ve added new functionality called “Summon material” which greatly helps with bringing the materialiq materials into your scenes fast and without any .001. 002 trouble.

Here is a video showcasing the summon material feature:

All 10 showcase scenes also now have their own Scene in Blender:

And last but not least the water got animated!

*Check it out, you might be interested. We’ve created a coupon code “ba” that you can use to get 20% OFF:) It will be valid for 1 month until 6th of August.

Hi Alphisto,
Excellent library and nice management. I purchased a few days ago.
Could you please help with a question?
The add-on installs in the addons folder under my .appdata folder, however I don’t want my Textures folder there. It seems that if I move the blend file and the textures to other location, the Materialiq manager does not “see” them. How can I point to another directory of my choice please?

Hi csimeon,
Thank you! Glad to hear it. We’re working on some additional fixes now due to be released very soon.

You can definitely point the addon to a different folder in it’s own preferences in the Addons.
Create a folder called materialiq and only move textures, blends_280 and previews folders into it. then you need to click on the folder icon above and choose the one you just created.

Let me know if it works.

We’ve decided to have the addon install like this because there are problems with Blender for example setting the path as relative (you need to click on the cog wheel and uncheck relative) and then people only set the path relevant to their current opened .blend file and it stopped working elsewhere … so it was a huge mess and this way it’s overall easier.

We might allow both ways in the future.

All the best and feel free to share what you do with materialiq:)


Yep that does it. It works thank you.

I’m excited to try out you node setups, particularly the uniform scale and the UV orientations without unwrapping that are very useful in Archviz.
This is just a quick thought, I saw plenty of features that seemed useful and wrapped in a comprehensive package.

Thank you

Actually it worked the first time around. Now I have lost the previews under “Summon Material” button, once again and when I click “OK” I get an error report.

Could it be that I have deleted the zip file since?
I thought it was redundant once the python add-on files have been installed under the addons folder and the Materialiq library forward has been set, in the dialog as above.

My folder structure under Blender Addons looks like this:

My folder structure for the Library, the Texture and Blend files looks like this:
As you may notice the .zip file is nowhere to be found in either, deleted.
In the Previews folder I have added jpg copies of the png image files to allow cross referencing with tags - I can’t imagine that makes any difference.

This is the setup in the Addon Preferences:

That was the problem! After putting them in a separate folder, everything works again!

Hi csimeon,

We already chatted through blendermarket’s interface but just to clear up here aswell, all this has been cleared up about 10 days ago with the newest update which fixed the issues with jpgs and pngs in the attached files.

There are no issues with this now.

This is how the new materialiq UI looks like:)



Hello Alphisto,
The new menu is nice.

Yes you have fixed the jpg/png issue in general.

  1. I had pointed out 3 materials that are missing texture images altogether, you have not fixed those:

    Please fix this.
  2. Also your installer “throws” the addon executional and the materials library 4.5GB total, all in one folder under Appdata/Roaming. In my opinion this is bad file structuring since most of us keep material libraries separate. Futhermore consider that many people have an SSD for system file and a HDD for data, to have fast operating system response. Appdata is usually under the User files in the C: disk, the SSD. You are cluttering the “slim” SSD disk, by default.
    So I tried to use the move button in the preferences, the folder button does not work and when I type the path I get an error message. It is not possible to move the library, smoothly from Preferences, not in this version either

    So instead of using the Move button I manually moved the bmaterialiq_b280.blend file and the folders: blends_280, previews and textures (leaving the python and other files under addons) and changed the “materialiq install path” to the new location. Summon material seems to work, but not sure I have not messed up some other functionality…

Regardless of the installation problems, I think installation should have two distinct paths: one for the executional, which you do not need to have selectable, after all addons go to …/scripts/addons folder, and another selectable folder for the Library.

It’s a good addon, the materials are very good, the functionality with the scenes and the webpage support is smart.
Please fix the installation.