Materials keyframe doesn't work in animation

Hi, so I’m making an animation in blender 2.8 and I need to animate the materials to change their transparency over the course of the animation. Unfortunately, when I insert a keyframe on my mix shader the slider become highlighted to show it has a keyframe but no keyframe shows up in the dope sheet. I inserted a location keyframe to see if maybe I just couldn’t see any keyframe in the dope sheet but location keyframes seem to work as does rotation, scale, etc. Although, inserting a keyframe on the materials still doesn’t show up in the dope sheet.

Thanks in advance for the help.

I don’t think the default shader has a transparency value in 2.8. Use a mix node and combine whatever shader with transparency node, slide the factor back and forth determine if 1 and 0 are full transparent or diffuse or vice versa, press i when hovering over the factor to set a keyframe for that. Alternatively you could set the factor to be full transparent and animate the strength of the transparency, I think. Anyways, I have a similar tutorial for 2.79, I’ve just tested for 2.8 and it’s not that different.

Hm strange because in 2.79 I would do exactly as you said but when I try in 2.8 it doesn’t seem to work or show up in the dope sheet panel? It worked for you in 2.8?

It looks like the option in the dopesheet that makes it only display keyframes related to the selected object is on by default in 2.8 for some reason. You have to turn that off in order to see shader related keyframes:

2 Likes

gahhh thank you sooo much I really appreciate it!