MB-Labs and Blender 2.8

I wanted to give MB-Labs a go and it says it is compatible with Blender 2.8 however I cannot get it to load at all. I first tried using the blender addon install with the zip file and nothing showed in my addons. So I went to the appropriate directories and all the files are installed, they just don’t show up.

I’m not sure if this is my install of 2.8, which I update regularly or something else. Has anyone else encountered this? Does MB Labs work for you?

This is a very common problem, it’s how Github packages the releases. It has to do with the periods in the folder name ie : MB-Lab-1.7.4… You need to delete these periods and rename the folder to something like MB-Lab-174 or whatever, JUST GET RID OF THE PERIODS. Blender assumes this is a file extension and gets confused.

This is one reason in version 1.7.3 the Auto-Updater was added (though it has a bug at the moment), was to allow people to update MB-Lab without having to go through the install process over and over.

If you download the Master branch as opposed to the releases this SHOULD install without issues - https://github.com/animate1978/MB-Lab/archive/master.zip

Excellent, that worked first time. Thank you for your help. This gives me a chance to have a play with MB-Lab and see what it can do.