Meandering Particles?

Sorry to bother everyone again, but I’ve got another problem. I’ve got a set of rocket engines following a path. (generic path, resized properly in edit mode) To make the engines light up, I used a particle effect from a small icosphere within the rocket. After tweaking the values a bit to make the particles go in the right direction, I parented the icosphere to an empty, and the empty to another empty, and then finally that empty to the path.

Now, I decided I wanted it to slow down when it starts thrusting (it’s descending for a landing) so I started editing the path’s speed IPO. This is where I ran into trouble. I edited it and most everything slows down like it should, however, the particle effects themselves continue moving as if I hadn’t touched the IPO curve for the path. The strange part is that the icosphere emitters for the effects (two, one on either side of the ship) move perfectly in step with the rest of it, but the particle streams keep moving independently as if they’re coming from nowhere.


version 2.33a

~Particle Effect Settings~

I don’t know what I did wrong, can anyone give me a hint as to how to keep these particles moving in tandem with the emitters?

blinks in confusion

Ooookaaaay, nevermind. It stopped doing that once I saved, exited, and reopened. shrugs

hit “recalc all” or enter and leave edit mode of the emitting particles, this will force a recalc, too.

blender’s particle system isn’t exactly flawless and has many limitations, but once you know what it can and what not, you’ll be able to make some good stuff with it.


I had tried both of those, and they didn’t work. But the problem seems to have just vanished when I saved and reopened.

bug? maybe should be posted in the bug-tracker at

i tried in the recent (unofficial) bf-blender testing build - enter/leave edit mode solves the problems and recalculates properly. which version do you have?

2.33a, as downloaded from two months ago.