Measurement of .obj file displays as 1 after import

I am sure this has been asked over and over but I cannot find a thread that addresses it how I see the issue.

I create a scene with units set to mm and scale 0.001, create an object in layout, size it eg 70mm, save the scene, export the object as .obj, import the .org file into a scene with preferences same as origin scene but the measurements in properties is showing as 1.

I use the object as a template to modify to required specs instead of starting over again from scratch.

How do I get the measurement to display as 70 not 1 without resizing the object.

Shouldn’t be every object in the scene have the scale applied so that you don’t have this:cubes
Left one is the standard cube scaled to 2, right one is this cube exported and import as obj. So it gets automatically scale apllied… Both cubes selected in object mode and then edges in editmode . The dimensions of both are 4m. You are talking of measurements but i think you meant dimensions?

The scaling in both scenes is the same, 0.001 and units =mm. I created the object as X:70 Y:18 Z18. When I import it again the properties show 1:1:1.

I’ve tried the same with metres and scale 1, same thing happens
I’ve tried using units= none (blender units, same thing happens when I import it.

How do I get back to seeing my original numbers?

Obj-files don’t store scale values so it is exported with scale normed to 1 and it doesn’t make sence to have different scales in one scene (cause of many problems). As i tried to explain: different scales but same dimensions:

If this is what you really want , what you really really really want then you have scale it down to 1/70 in edit mode and up to 70 in object mode.

AHHH! Thank you. "

What format should I use?

Why do you want different scales (there are no measurements in properties) in one scene?? Look at the dimension they should be 70mm and that is what you want: a reference object with a specific dimension.

I have found my answer through trying the options by trial and error, but many thanks for your help. The obj files not storing the data was the turning point!

Its the dimensions I need to keep and I have found that storing the object I want to use as my template as a .fdx file keeps the data.