memory leak in blenderPlayer?

i’ve been working on a game for a museum when i stumbled across what i think might a memory leak in the blenderPlayer. i created a little test scene where all it does is set a camera that shows a shadeless susanna. it works fine when its run from within blender itself but when i go to run it in the blenderPlayer i always get this error.

__NSAutoreleaseNoPool(): Object 0x1034faa30 of class __NSFontTypefaceInfo autoreleased with no pool in place - just leaking

i’m running on a mac 10.6, do pc users get the same error or is this a mac specific bug?

id attach a a zip of the blenderPlayer app too but the attachment uploader seems to dislike zip files for some reason, this means you’ll have to use the save as game engine runtime and open the binary file to repeat the error, sorry.


testBlenderPlayer.blend (528 KB)

I saved as runtime on Windows 7 and have no errors. Maybe try the latest test build release for Mac:

i tried the new build (didn’t even realize it was out yet), the leak is still there on the mac side tho

Open a bug in the bug tracker. According to a little bit of googling this is an issue of the application.