Merging vertices does not merge coplanar faces. How do I solve this?

A problem I run into with Blender, repeatedly, is that I extrude edges across an existing face, or series of faces. This of course creates new faces, because that’s waht extruding edges does. =) Even though new vertices have been created wherever the new edges cross existing ones, the existing faces are not split (autosplit edges and faces is checked and activated under options. First thing I looked at!) and thus the new faces are now coplanar and z-fighting with the existing faces. Alt + M vertex merging does nothing to get fix this problem with the preexisting faces not being split. Nor does it do anything to either remove or integrate the new faces.

I am curious to know if anyone has a solution for this other than what I have been doing, which is deleting all faces, and reconstructing all faces individually. This is a waste of time in my workflow that I would like to fix.

I would really like to see blender do a better more intelligent job of handling this sort of situation in modeling. It should be handled automatically. Good grief, even SketchUp does that…

Destructive extrude is being worked on. It sounds like what you are after. It’s in 2.90, not sure about 2.83

Oh! Arigato John! I’ll give 2.9 try. I’ve been thinking about trying that one anyway. Nice to know there is progress in good directions for Blender. This is great software and I can do things I wanted to for years, so when I come across little things like this it surprises me sometimes
*Edit for type error.

1 Like

You were right, destructive extrude was what I want. 2.90 works well so far. Arigato gozaimasu! :bowing_woman:

1 Like