Mesh Is Very Off Center

I cannot view my model when importing, it seems to be so off center. by 1.0e something

I Import a model and it is so off center that I cannot locate it on Blender.

Blender does not seem user friendly, either, with zooming around and locating objects.

It is off center by 1.0e Inf

Hit A key to select all objects(hide camera/lamp etc first), then hit numpad . (period/dot) key to zoom in on the selected objects
Or open the outline panel, select the object then hit numpad .

Before importing ensure the 3d cursor is at the scenes origin.

Do you link it or what do you do?

If you link: make sure that your model(in another blend file or just somewhere else) is at the center, and then in your scene import.
Did you put your 3D cursor at empty place on the screen, which goes to far away to gray background? If so: Shift+S and select “Cursor to Center”. Maybe could work.

Maybe that can help. :cool:

Hit N to open the settings side panel (something I like to keep open by default). Select your object using the object heirarchy, which should be the window to the left of the “Game Logic” window setup. At the top of the settings side panel is the X, Y, and Z coordinates of your currently selected object. Set those all to 0, and your object should be at the start point.

Try Alt-G, clear location, it resets a selected object to the center of the 3D world.

In case the object pivot point is way off, you can hit Shift-Ctrl-Alt-C before and move the geometry to the object’s origin (pivot) or vice versa.

why creating a new topic?

Moderation: I’ve merged the two threads together into one.