mesh singled sided problem?

i am making a game at the moment but i have a problem, and in my opinion its there by default, but for example i have a tree made out of a circle mesh extruded several times.
when i see it the 3D view its a tree, but when i start the game the faces of the mesh that are always facing the camera are invisible.

i do not know why this happens, yet how to enable/disable this.
any suggestions??? :confused:

this i driving me CRAZY!!! :spin::mad:

this can be caused by:

  1. u didnt give the object some textures/materials, then it looks somehow strange and or singlecolored


2 the normals are not set the point out of the objekt, this offten happens with mirrored objekts, like mirroring in the z axis and not connecting some faces,
then when u press strg+N all faces try to turn to the outside,
when u press strg+shift+N then they all try to turn inside.

Faces turned away, u can not see (u would have to turn the TwoSided option on)
to fix such problems u would have to select the object, turn on showing of faces normals and change them when they dont point out.

greets equal

There is no need to turn on “two-sideed” for closed objects. In fact it has impact on performance, because it renders two faces (front and back) while you can never see the inside face. Better flip the normals outside as described above.

thanks you guys have been really helpful, but does this work for the game engine?
because when i put the camera inside an object its invisible, but its only visible from the outside

If you need your object to be visible from the inside AND the outside, then yes, you can enable the twoside option. To do this:

Go into editmode
Add a UV layer to the object (select all, hit U, and choose “unwrap”, if you’ve already textured the object this should already be done).
Go to the editbuttons and click on the Texture face tab
Choose “Twoside” and then click on “copy”



THANKYOU!!! it worked!!! thanks for all your suggestions!!!