Mesh tearing apart

When I want to move my mesh, it is tearing apart. It is joined, therr is no problem with joining into one mesh. That joined mesh is tearing in Pose mode when I want to move it and rotate it. Can anyone help me?

Looks like you have gaps in the mesh, i.e. the arm is not joined to the rest of the body. To know for sure we would need to see the blend file, can you post it here, or to here: then post the link from this website to your file.

I’m guessing you downloaded this mesh from the internet somewhere and it was not made in Blender, since its made of Tris (three sided polys) not Quads (four sided polys) as would be the case if it was made in Blender.

The remedy is to merge the duplicate vertices along the break line together, before you pose the mesh. It is a good idea to remove ALL duplicate Vertices in a mesh as these will cause major problems when animating.

To do this go to Edit mode, select all vertices and Merge by Distance with a very low figure, or 0. Then check this break line again for any other errors.

Cheers, Cock.

PS. If this is multiple Objects, you need to join them together, then remove Duplicates…

I tried to merge it by distance, but it didn’t worked. I asked on Discord what is happening and I got a respond;

I don’t know how to do it by myself, I’ll upload the file for you to take a look

OK, I’ll take a look for you…

OK, A question: Where did you get the Armature from, ALL the bones have zero length, i.e. the head and tail of the bones are coincident. And none of the bones appear to be connected to anything else…

I don’t see how this can possibly achieve a weighted parent, since the bones have no dimensions and therefore how do you associate any vertices to the bones?

Where did you get this from?

Cheers, Clock.


The response you posted from Discord is utter cr…

I’ve converted it from one game. So could you explain me the problem, please? What happened? And do you know how to fix that tear apart problem?

Not sure I have the faintest idea! but the Armature is not good, bones are not connected and the bones have no length, so can’t bind to the mesh.

I added my own simple Armature:

And then parented it to your mesh with “Automatic Weights” then rotated a couple of the bones:

As you can see it worked and did not tear the mesh apart. So I can reasonably conclude that the Armature you have is no good and that the resolution is to make a new Armature and then do a simple “Automatic Weights” parent and weight paint as necessary as a post process, if any of the weights prove to be not quite up to required standard. It is important that the bones are in connected chains for this process to work effectively and the joints are in the right places!

I should point out that I have done nothing to your mesh in this process!

Cheers, Clock.

I fixed the problem!!! But niw I have problem with some texturing, would you like me to tell you more details?

Yes please! :grin:

I’m trying to texture one character but every time I connect nodes the model is all black
On discord I was told that my texture is normal texture
I don’t know what that means
Would you like to see my blend file with textures?

A “Normal” texture is one used to set the normals (perpendicular face alignment) of the mesh polygons, see

Generally it should be fed through a “normals” node. What you need is the Texture Image that gives for example, the colour and pattern of the clothes, see

There is also a “Bump” image, which sets the small distortions on a finished mesh, so for example the creases in clothes, see

Yes, post your file with the images packed so I get them…

If the makes the file too big, just send a screen shot of the images…

Just one question, Have you UV mapped the mesh?

Cheers, Clock.

Here is the file
emily1.rar (1.3 MB)
I don’t know if I did this…

Ah! Please don’t “rar” it, I have a Mac and the only unraring thing is full of spyware!

How to send you whole file with textures then? Do you have some idea?

just post the blend file here, or to and post the link to your file here, if you pack the images like I said previously all will come in the blend file.


I managed to open the .rar file, but not ideally and there seems to be problems with your materials! None of them have an Image Texture Node, so the images will never be used as the “Colour” for the material. When you have an Image Texture, you must also have a UV Map Node to tell the shader where the UV is in relation to the image. So take a look below:

Here are two primitive shapes and a basic material. In the Shader Editor you can see I have added a Image Texture node with the image to feed the Base Colour socket of the material. I have also added a UV Map.

Now another picture:

I’ve now gone into Edit Mode for the cube and selected all the Vertices, you can see how the UVs fit onto the image I have used for the material. This is what you have to do in order to use Image textures!

Here’s the blend file, can I suggest you practice with this technique so you are familiar with it before attempting to do your own model. You may well find you have to alter, for even redo the UV map for you mesh in order for the material to work properly. you will note I packed the Image into the blend file, as I said previously, this makes life easier for you…

materials.blend (1.9 MB)

This will not be easy for you as I have had a look at your UV map and it is literally a crock of… sorry not being rude as I guess you didn’t do it, but it will need remapping…

This is your mesh and UV map:

Not good, so please understand the principle first then we can look at sorting out your file! Did you make this mesh, or download it from the Internet? Oh yes, I forgot, the armatures are no good either, if you are getting files from the Internet, please go to a resource that specialises in Blender formats to start with, like for example. :laughing:

In the file I sent you, try scaling, rotating and moving the UV map elements and see what effect it has on the colours of the cube… You won’t see UV elements if you don’t select the vertices in the mesh in EDIT mode in the 3D view by the way.

Cheers, Clock.