Mesh unwanted reflection

Hi. I have a mesh simulating the ocean and a cylinder going through it. I get a reflection of the cylinder that I would like not to have.


I tried to turn off the transmission of my cylinder and that helped to get rid of other unwanted reflections, but this one Its still there. I also tried to tweak the display options of my ocean…but that freaking reflection is still there.

Do you know any workaround to solve this. I need to show an ocean and the things should not be reflected on the sides.

Thank you

If you use eevee just turn of “screen space reflections”, but that will kill all reflections.
Or you assign a different material to the sides and set roughness to 100%.
Another hack would be enable “refractions” under “screen space reflections” and then turn “refractions” on for the material that should not be reflected.
There is a way with materials index and light path, but i did nt use and know it.

I am using cycles :frowning:

This will work with cycles, but did know how. Maybe search for solutions “cycles material no shadow”.
Here is one that may work for you:
or perhaps complete

1 Like

Thank you. I am not sure if what I am seeing is a shadow…looks like a reflection. I am still having this issue.