Messedup Normals

Hello again,
I have made some meshes in Blender and when I export them, their normals seem messed up in two different applications. I have tried the .x and .obj formats since they are the only common formats between Blender and the other applications.

Recalculate normals outside, doesn’t help, since the normals seem fine inside Blender, they get messed up when exporting I guess.

Here is how one of the meshes I’m talking about, render in Blender:
Click to enlarge

And this is how it looks outside Blender:
Click to enlarge

Is there anything I can do to fix this?
Thanks in advance.

I had such a problem and the reason why recaulate normals outside didn’t work was having faces inside the object (to be correct: edges, where 3 faces meet). For example you model a pipe, duplicate and mirror it to the X axis and merge those parts (+remove double). If the pipe was capped on the side of the mirroring axis, then extra faces appear inside the pipe which makes recalculate normals go crazy. You can check for such artifacts by switching off double sided on the editing panel (F9, mesh tab, at the bottom) or enable showing normal (F9, mesh tools 1 panel, draw normals). Don’t know if it helps…

[for me it seems, that your object is simply smoothed, nothing else…]

Thanks for that information poison. The geometry of the meshes I’m exporting now is very clean, but it seems that the normals are pointing wherever they want to though.
Well anyway, I guess a good normal map will fix that.

Well, the normal maps did some work, but still it is not smooth shaded. If I turn on smooth the results are the same. Is there any way to fix the normals without adding new faces?
Like edit the normals or something.

This is what I have so far.


Try manually selecting the offending faces and flipping its normal.