Mipmapping for individual objects.

Does anyone know any way to activate/disable mipmapping for selected objects/textures.

The reason I ask is im creating a little space scene and I have created a skybox with my seamless starfield texture on it. The trouble is because of the mipmapping the starfield looks like it has seams. I would only like this option for the star field becuase it is a drain on performance and not needed on anything else.

Free kudos for anyone that comes up with an answer :).

If you use a texture, there is a mipmap button in the texture settings of the material section.

Thanks for the reply fireside but it doesn’t seem to change anything, (blender materials enabled).

I never actually tried it. Thanks for that. Now I know. I would think that’s your only chance at an individual solution.

Your other option is to try to turn off mipmapping in the graphics card settings but I wouldn’t recommend that. Perhaps if you made the texture high res enough it will minimize the effect of mipmapping.

As far as I know you can only enable mipmapping for all or for nothing.

To solve your problem you can change the UV mapping of you skybox that it does not fit the complete texture. With starfields this shouldn’t be a big deal.
I remember there was a long thread regarding seamless skyboxes half a year ago. You could try to find it.

In GE there is always mipmapping enabled. But in my Video Texture player I allow to enable/disable mipmapping for performance reasons. I plan to extend this plugin to be able to load single images - that could be a way to manage mipmap setting for every single texture…

Monster - Thats what I ended up doing however it does limit the detail you can put into it. I had to combine this with a skydome instead of a skybox to get an result. I might combine it with another texture overlayed on top for the details.

Ive noticed lots of games have mipmapping but it doesn’t seem as extreme as blenders, it seems to blur thing way too close to you.