Mipmapping Solution...

I was wondering if Blender 2.49 has a way of softening the mipmap feature for images so that it would be more subtle? Specifically, the hard edges is what I’m referring to. Is there a way in Blender to soften the “transition” between the normal sharp image, and the blurred so that it won’t be so noticeable?

Thank you very much. :slight_smile:

the only way is to scale up the texture. Mipmaping is a digital (as in on or off) process. You can have multiples of it but not fractions

Damn this misleading thread title! I thought you’d come up with a way of having mipmaps turned off in a game permanently and at runtime. The work arounds just don’t cut it for me…

The only way I could think of solving the problem in a specific render is to turn mipmapping off for the specific texture you refer to.

Apologies for the title confusion. For those who don’t know, to disable the mipmap feature you have to pull down the top menu bar and go into the “System & OpenGL” option, then find the mipmap button and click it off.

This will only cause more problems however with lines and fine detail.

The only option I could find to lessen the impact of the mipmap edges is to make your textures as dark as possible with the least amount of contrast that you can get away with. That way the effect is more subtle. Otherwise, if you click it off, you will have to skip giving your scenes any real fine detail, because it will look terrible.

So far, I haven’t found one free software that tops Blender when it comes to game authoring. I like the concept of mipmapping. However, I just wish I knew how to refine this particular feature a bit more, as it would do wonders if there were no sharp edges to worry about.

I attached an image to show how darkening your textures can make the mipmap effect more subtle. The edges are still there, but it’s a lot harder to notice them now.