mirror weight painting not working, rigify.

1.Using rigify for this model, and the result has been quite good so far, but now I need to adjust some weights Issue is, that x mirror is not working. I tried it earlier with this model with a non-rigify rig and the x mirror worked fine. The bones are all named properly, by rigify. Everything is centered and zeroed out.

2.Is there a way to see textures when weight painting?

Here is the blend file. What I’m working on is located in the Scene titled “Tracer”.

2 Things, under the Options (under the X Mirror), click Topology Mirror, that seems to help a bit. And in Tools, Tick Multi-Paint. You can select bones with Shift+Click and De-select them with CTRL+click (I use LMB but you may be using RMB)

Sorry just noticed you are using all tris on the model. haven’t worked with game models.
Excuse the post.


Does that have something to do with the mirror weights not working?

You need your object to be symmetrical to use x-mirror. Your model currently isn’t

Note the centre of the object is not on the centre line of the mesh

Once it is symmetrical you can use the X-Mirror option to paint both sides

Ah, that’d do it. I’ll give it a fix and hopefully it will work.

How to i get it centered???
I set x to zero, did not work, I visually moved the mesh in edit mode as much as I could and that did not work :confused:

Reposition the object origin. Position the 3d cursor where you want the origin to be (you can select a vertex on the desired mirror plane and use Shift+S / Cursor to Selected) and use Set Origin / Origin to 3D Cursor in the toolshelf

Also looking at your model, it’s not symmetrical anyway