mirrored multilayer openEXR files?


Every time I import one of Blender’s multilayer files into an application that accepts multilayer openEXR files, it comes in vertically mirrored.

I have had this happen ever since Blender got multilayer export ability.

I have had this happen in every program I have tried to import the files with. This includes: After Effects (using: http://www.fnordware.com/OpenEXR/), DJV (http://djv.sourceforge.net/), fusion, houdini, and I think shake.

Does anyone know how to fix this, or is it a genuine bug I should report?


Kevin W.

i had the same problem recently.
although it´s pretty simple to work around, it´s still annoying.
was wondering who is to blame, blender or third party software :wink:

Edit: hey and thanks for that djv utility.
I have been looking for something like that for ages.

I think we should blame today’s youth. They are so out of control with their rock and roll and dancing.

I know it’s usually a simple fix in post, but if it is a problem in Blender, then I think people should know about it so it can get fixed some day. No sense in completely ignoring a bug.

On the other hand, if it’s just my software/settings, then I would like to know how to fix it, and I’m sure there are others who would benefit from that solution as well.


same issue for me using AE

just tested in Fusion 5 and same problem as well.

Yeah, I’m thinking it’s a bug. I usually export separate EXR files which work as they should. But for multilayer, you have it flip it.

Someone should put this in the bug tracker thing, I just don’t know how to do that.


I just tested in Nuke again and they are still upside down :frowning:

Another thing I would really like would be some options for naming the Passes differently,
so for example you could rename the _Renderlayer_Combined into rgba so you wouldn´t have to throw
an extra shuffle node in after every read node. ( whishfull thinking hehe :))

Hello everybody,
I am following this discussion with great interest, because I think the same with the files “Multilayer”. It would be great to work well!

Also I would like to know As you have solved this problem (in AE, for example),

i am on 2.49b and they still come out flipped. easy to fix but annoying.
who can get this fixed?

Yup, still flipped here too. I just threw a mirror into my Blender Nuke gizmo. In AE I just set the v scale to -100.

Still, we should not have to do this (none of the other image formats are flipped). I’m guessing it’s an easy fix but I don’t know how to code for Blender so I’m useless there. Otherwise I would have fixed it myself. I know multilayer was intended for blender only, but I think it’s time that part “grew up” so I can finally convince people to use it in production.

Perhaps it needs to go into some bug tracker somewhere? I don’t know how that system works :frowning:

Kevin Whitfield

i use nuke too. combined not going to rgba is annoying too as mentioned before.

Yes, here too with Nuke, have to use mirror node on multilayer. Mentioned here on BA numerous times and on Blendernation. Bug report needed :slight_smile:

I’d like to see the Image Node in blender read multilayer from other renderers like VRay and Modo instead of ignoring them too

The real question is – whose file conforms to the specification, or is the spec possibly ambiguous? I’ll post this up the chain to Ton. He’s the one who took the multilayer spec proposal to the EXR people in the first place.

You know what would help any investigation? If one of you folks with other software could use it to generate a multilayer EXR file, bring it into Blender and see what happens. Is it mirrored? One last thing would be to generate a ML EXR from Blender, bring into one of those apps, mirror it to correct, then resave it from that app as ML EXR. Then someone can compare those two EXR files to look for differences and see which one conforms to the specification.

Blenders image node doesn’t seperate the layers.

How do we know blender doesn’t just treat a multilayer as a ordinary combined exr, as there is no issue between blender and other apps with regard to straight exr’s.

It would be a more valid test if blenders image node was made to read multilayer and separate those layers out into individual outlets on the image node. So testing other apps implementation in blender is not possible.

As it is now, how do we know blender just doesn’t treat 3rd party multilayer exrs as straight ones?

I’ve tested VRay multilayer exr and Modo import they import int he right orientation but no layers. This proves very little.

Can all of those major apps have implemented multilayer incorrectly. I don’t think so. :slight_smile:

Well, as the original spec is based on Blender’s implementation, I’m not sure what to think.

yellow – just did a test, and I don’t see what you see. I used Blender to generate a 3 layer, multipass OpenEXR file. Started a new session and loaded that EXR through both the Image/UV Editor and an Image node. All three layers and all individual passes are perfectly accessible. Below is a link to the file. Can you test how this comes into Blender for you? Can you also test it in another app? Are Layers/Passes visible? Thanks

Test file (1.3 MB)

have a look:

Blender multilayer to Nuke, Nuke reads blenders renderlayers, but image upside down on all layers.

Mirror node vertical out of Nuke multilayer back into blender. Blender ignores it’s own named render layers and shows the image in the correct orientation as per Nukes mirrored image.

I think blender just reads any exr multilayer or otherwise through the image node as a straight exr.

Rendered multilayer out of VRay and Modo. Nuke read them correctly.

Blenders multilayer rendering is wrong.

Harkyman, you’d be even more of one of personal blender heros if you took this on. I know you can do it. :wink:

Point of fact – Saying that “Blender ignores it’s own named render layers” is incorrect. Once Nuke resaves that file, it will be using it’s own encoding. Also, saying that “Blenders multilayer rendering is wrong.” is not supported by the evidence. What is supported is that “Blender’s multilayers don’t play nice with other apps.” Who is right or wrong depends on who conforms to the specification, which is yet to be determined. As I mentioned before, the spec might also be ambiguous which could create a situation where different implementations don’t play nice but meet the spec. What we do about it is a different question, but I feel the need to be factual.

Any chance you can post for me that EXR file that Nuke generates? Don’t even mirror it. Just throw it into Nuke, confirm that the layers/passes show, then export it from Nuke. I’ll take a look at the result. Thanks.

Ok, from the horses mouth. :slight_smile: OpenEXR’s own exrdisplay tool refuses to display your EXR, well just a black screen, adjusting exposure does nothing either. Yet it shows all Nuke, VRay and Modo multilayer exrs I’ve tested with correctly?

Have ILM got it wrong as well as every other app out there? :slight_smile:

I know you need evidence and appreciate your involvement. I’ll post the file as soon as I can.