Missing faces from Sketchup models?

I’ve googled and searched the forum, but not found an answer for this.

The model displays correctly in the viewport -


But loses faces on render -


I see this all the time so I assume it’s a common problem. What’s the deal?

Nice object!
It’s probably a “wrong normals” problem?!
Enter Edit mode, select all faces and do Ctrl-N keys.

It’s not mine, I got it from Google Warehouse

I tried ctrl-n earlier, it made visible faces disappear. Also double-sided is on.

Control Shift N?

Alas, no. Wouldn’t double-sided handle such problems as inverted normals?

Yeah, google models are flaky.

It looks like some of the normals are correct and some of them are not. I have run into this phenomenon as well. The solution is to manually edit the normals of the model.

Select the model. Enter edit mode. Choose FACE selection. Press F9 to bring up the editing tools. Under the TAB Mesh Tools More click the Draw Normals button and set the NSize to something big like 10. Now little blue lines will show you which direction the normals are facing. Select the offending faces and press W-KEY followed by 0-KEY to flip only those normals you selected.

Every model I have pulled down from Google warehouse has needed “fixing-up” so simply consider it the price of the the free model.

“Ass, Gass or Grass, no one rides for free…”

Even that didn’t work.

I’ll consider these google models to be for reference only and stop wasting time with them.

If Ctrl-N fails ( some are good, some are bad), probably the model its not “closed”/or have doubled vertices?!
Select all faces/verts and press the “Rem Doubles” button
Try again…still not working? Your model have some gaps…try to find them and “close” or act as Atom suggests
And disable double side, not needed.