Missing IPO? vers 2.48

I created an armature, did “I” for every bone!
then copied the armature.
I need the copy to move differently, so i thought i would change its ipo.
no ipo!
yes it works.
any idea?


octopus3bu.blend (505 KB)

I don’t know if I understand, what you want to do.

But if you insert keyframes for bones in PoseMode you have to set the IPO type from Object to Pose
(In the header of the IPO window) to see the IPOs


Thanks Patel
but yes i have it set to pose, no ipo na yes it works!

What Patel said.

I also want to add that animating bones is usually done in the action editor. So if you open the action editor you can see next to the action name there is a number 3… click on it and make a ‘single user copy’. This duplicates the animation information and applies it only to the current selection. You can now change the animation in whatever way you want while that action is selected.

If you look in the ipo you will also see that all 16 of your ipos (one for each bone) were duplicated accordingly. Huge time saver!

I just saw your reply to Patel,

when I opened your file the IPO window was set to object…

thanks all
i have been using a much larger file and the ipos were missing - thanks to Patel i have now found them.
Thanks also to feelgoodcomics - now i need to find the action editor!

Oh really? You don’t know how to find the windows? How did you make it this far? I’m impressed lol :slight_smile:

The action editor can be found by clicking the button at the far left of any header, and selecting action editor from the rollout menu.

i change it to single user copy (from 2 on current file) but when i go back to it it is still “2” plus it created another one.
please explain!

i even tried deleting them with the X - they come back!

I strongly recommend you take some more time to study Blender before tackling something as complex as this! Once you understand what is happening, the behaviour of the program will make more sense to you.

To answer your question:

When an animation is linked to more than one data block, it has a number next to it greater than 1 - which represents the number of data blocks it is connected to. So creating a single user copy in your case didn’t remove the second data block, that’s fine. It should have still worked as expected… once you clicked the single user copy were you able to change the keys and see it effect only the one bone chain?

Using ‘X’ will only unlink the data. The data will remain in the file, but will be flushed when the scene is closed if it is not linked to anything (which is symbolized with an ‘O’ next to the name). So in order to delete a data block, you have to unlink it from everything first (which can be tricky sometimes, but I imagine this will change in 2.5)

good luck!

thanks very much

see the movie so far.