mist+grass issue (blend file)

As in attached file ( is just a small part of some scene I,m working on ,and I put 4 cubes to make a difference between :mist on normal object ,and mist on grass…so…I know…this scene is ugly,but is just an example)).The mist work fine with all object I have in my scene ( there are many various object with uv texture) ,however no mist effect on particles grass…I try to change any setup…and after two days I,m very tired…please…help…probably is some stupid error …
mistISSUE1.blend (1.18 MB)

I think the problem is that you have the ‘Height’ setting set very high, so not only is it decreasing the intensity of the mist everywhere incl. the cubes, since the grass is so low to the ground, it’s having even less of an effect on the grass. Try decreasing the height value by a lot, and then readjust the mist settings so that it looks how you want it to.

Hope this helps!

noooo…blend file…you can set it and then you see, height is no problem here…