Mix shader not mixing [Cycles 2.62]

I have been toying with cycles lately and after downloading the 2.62 version of blender I found that the Mix Shader in Cycles is only choosing 1 of the inputs as the control (the top input) I am not sure if anyone else has had this problem but it is unfortunate at the moment I really like how cycles does things. Any help is appreciable.


I think that you have to play with the roughness value (not so high) of both shaders until you get the effect you want.

That doesn’t change the mixing at all. I am trying to mix a white diffuse shader and a red gloss shader but it will only render out the diffuse shader for some reason. I have tried changing to different shaders and changing roughness, ior, factor etx… Nothing has worked even the add shader takes only the first input, I have also download the newest version from graphicall which has the sam problem for me also.

EDIT: I have found the problem to be OpenCL, while it rendered the standard materials it wouldn’t work for mixing them together which is strange.