More lights = more noise ??

Hi guys,

I have a city scene with an HDR and some area light inside a building.
Everything looks pretty nice and smooth so far, as you can see below:

But when I add several other area lamps facing up outside, the lights inside the building gets horribly grainy.

Both renders have 600 samples, 2.79 Cycles, here my other render settings:

How can this be possible? :@

ps: maybe it’s important to say that the area lights in the first picture are part of the project, while the ones added in the second are instanced from another project.

Thanks in advance to who may help me!!


Individual lights need to be sampled separately. With your current render settings, Cycles will just pick a single lamp at random on each sample. So instead of 600 samples to just your area light and building lights, that 600 samples gets spread across ALL the lights. If you change your integrator under the Sampling panel to “branched path tracing” you will have the option to sample all lights on every sample. This is obviously slower to render though, and branched path uses a lot more memory on GPU…

Didn’t know this one… thank you Ninja! :slight_smile:

+1 for branched path.

make sure you have sample all INdirect off. this will improve speed, but reduce quality and brightness of small areas, like indoor.

I’d set those tiny spots to not be visible to diffuse rays

Turn off “Multiple Importance Sampling” on your light’s emission material. Since they aren’t contributing a lot of the light in the scene - this doesn’t need to be on.