Motion Blur in Smoke simulation?

Hi all, is There any way to have motion Blur in Smoke simulations? If I activate It in cycles render It doesn’t seem to affect the smoke at all. I Guess It is not supported. Even the vector pass is blank. Am I doing anything wrong? Is There a workaround?

Thanks in Advance!

I think there are no options for sub-framing a smoke simulation, so the best advice I have at this point is to slow it down by, say, 5x, and then composite the frames all together in post to get it back up to speed. Not an expert though. Hopefully someone else will have better advice.