Motion Blur questions/ issue

OK… some strangeness occuring on motion blur.

I took a couple existing projects that were created in 2.69a official. I did a save as and made a copy of them (so I still had my originals.

So I open up the first one in 2.71 official…and this is what I see. Note that it is greyed out and you do see a deformation checkbox.
This was actually a project that I used for just still renders.

I then open a second project file in 2.71 (again originally created in 2.69a) and see this in the motion blur area.

Now this file had character animation and other object animations in it. I tried selecting both CPU and GPU to see if anything changed, but it did not.

To further complicate things… I then reopened the original file started to switch between GPU and CPU and then the motion blur switched back to what you see in the 2nd example image.

Here are my questions…

  1. Why on neither of these files is the deformation option now not showing? Do you have to enable something in user preferences maybe, or select the objects that you want deformation blur to occur and apply some setting there.

  2. Would it be better for me to start with a brand new 2.71 file and append all the objects into these scenes? I would like to avoid that because then I may lose the animations I have in that 2nd file.

I’ve been out of the loop in keeping up with the improvements regarding motion blur. So I need to read up more on how to properly set up motion blur in 2.71. I see this new shutter amount which I assume makes the blur stronger possibly.
But what I really would like to know is why do I see these 2 completely different motion blur setting boxes appear on these older files that were opened in 2.71

@IkariShinji Yes, I am using windows 7, 64 bit. I haven’t even tried rendering anything yet… I’m just trying to figure out why I am getting these different motion blur settings appearing on different files.

Uh…those aren’t even the same panel. The one with deformation options is the object-specific motion blur settings, the one with the shutter time is the global motion blur options in render settings.

J_the_ninja … The screen grabs above came were in the exact location… where I have always accessed motion blur… in the render tab… in the motion blur section…

I think something is just screwed up with this file that was originally created in 2.69 and then opened in 2.71.

If all things are correctly done… where / how do you access this new deformation motion blur?

This image: [ATTACH=CONFIG]318179[/ATTACH]

If that’s from the render panel, why is there a custom-properties panel? That is not present in render settings, only object settings.

Well… I guess you are absolutely correct J_the_ninja. After seeing your post, I went back and checked. When I opened up the first file in 2.71, I must have had the object panel selected, when I thought I was in render panel… the greyed out motion blur immediately caught my attention and because it was in about the same location where motion blur is in the render panel, I probably just thought I was in render panel… if that makes sense :slight_smile:

So will someone please tell me … if I have a character that uses an armature will a change in poses AUTOMATICALLY give the motion blur or do I need to select the armature or mesh and somehow enable this new deformation motion blur.

Yes, deformation motion blur will kick in when needed by default. If you want to disable it for a particular object, you can uncheck that “deformation” box. Generally though, you can just animate and leave things as they are. Cycles will take care of the rest.

I’ve been too lazy to set up a test scene yet but has anybody tried the deformation blur yet? I’m curious what kind of rendering time penalty it has, since I assume this code is based on the aborted GSOC 2013 project, and that was rumored to be pretty slow.