Mouse lag in Blender

Hello,

I have tried to :

  • change my drivers (zBook 17’, K3100M)
  • use older versions of blender
    No way to get rid of this mouse lag so I cannot use Blender on my machine.
    I have tried to change some openGL parameters in Blender but no result as well.
1 Like

I’m not sure this is the same issue, but I had a similar problem that plagued me forever on my laptop. I finally figured out that if you put blender in fullscreen mode it fixed it. Try that. (Alt F11) See if that fixes it.

Yap, same issue for me. :unamused:
Haven’t used blender for some years now,
and when i use it again today the mouse lags quite a bit each time
selecting something and trying to move it around.

Any change of position to either objects or vertices only get rendered
after zooming in or out .

Very annoying and mouse-handicap and it only accures in
blender and non other program.
Also tested it on only one single and simple object with all
subsurfacing modifiers turned off and non vertex-heavy objects
on all layers.
Has no solving effect. :frowning:
Anyone have an idea what the cause could be ?
Thanks so much for any useful hint :slight_smile:

I have noticed that enabling G-Sync in both full and windowed mode causes this problem for me.
So, to fix this problem go to the NVIDIA Control Panel application, select: Display/Set Up G-Sync
Then select enable for full screen mode