Mouse look stutter and freeze

HI I had this in another section of the forum and was suggested I try else where for more feed back, so hopefully someone else has come across this issue before, The mouse look script works fine when using all the blender game modes apart from when it is exported as a exe then it will run for a few seconds stutter stall out and freeze its like its not picking up the signal from the mouse Windows 8 issue ?

The controls are WASD and mouse look

Cheers for any help


Sandbox_Logic.blend (266 KB)

Remove the always sensor
Enable true pulse triggering at the mouse movement sensor.

Here is a capture of the console, as it appeard for just a nano secound it was a mission to capture The same message appears with the defualt mouse look 2.7 scene when exported as a exe which also gets the same errors ie stutters and will eventualy freeze.

Hello! It works fine on my computer (windows 7 64). But why are you using a mouse movement sensor? It is not necessary with this mouselook script, isn’t it?

Just seeing if it would help I’m new to the game engine just trying to understand whats going on I also tried it with a always sensor as well , I will try it out on a windows 7 pc and see if it works cheers for the feed back.

I tried it out on a gutless note book and it worked fine, I also done some more trial and error with windows 8.1 and the above pic is the only way it would work not as smooth as inside blender but at least its reliable, if the mouse movement sensor is used it stilll freezes and stutters some kind of windows 8 issue i think ? I will take my pc around to my brothers pad to see if any windows 8 updates fix the issue.

So yet more testing trying to figure out what is going on, I Installed the windows 8 updates and also the latest nvidia drivers, still the same problem . I then installed windows 7 back on my pc just to rule out the problem being related to a windows 8 , no luck there either so while out for a walk I began to wonder if it was a vsync problem, and sure enough when I turned off vsync in blender or in the nvidia control panel the problem went away.

There seems to be some kind of vsync control war going on between Blender and my Asus 660TI video card. Turning off vsync in the nvidia panel gave blender control, adaptive and on settings worked fine, but as soon as I gave control back to Nvidia the the blender vsync settings caused a conflict.

The method that worked best for me was to set the nvidia vsync setting to (use the 3D application) and turn off vsync in Blender.

With this setting there was no need to have my temp solution of 1 logic tick in the always sensor, hopefully this info is useful to someone else out there and saves them the mission I had.

Just wish I had thought of it earlier :spin:

Yeah Windows 8.1 here and it works fine. The reason that Vsync does that is because there are slight variations below the target frame rate (example 60fps (like 59 or 58) so when your control panel is forcing the GPU to render a maximum of 60fps, and Blender tries to force the engine to run at 60fps/30fps (depending on whether it is adaptive or not), that extra 1/2 frame(s) come back to haunt you eventually, causing a stutter.

thanks for testing the file and the info @MrPutuLips