mouse problem in 2.66

In Blender 2.65 i was able to zoom with my magic mouse by scrolling. When i scroll in 2.66 it is rotating the view in the 3D-viewport and panning in 2D image viewer… how can i fix that? I was using the magic mouse under OSX Lion without any issues for a couple of years… for zooming i just had to scroll, for rotating the view i hold down 1 and move the mouse and for panning i hold down shift + 1 while moving the mouse… i compared the whole User preferences of 2.65 and 2.66 and they are exactly the same. ! :confused: i even deleted my whole Libary and reinstalled 2.56 and 2.66

Same problem here… Is there an easy fix i’m missing?

Solved it. It just took some playing around.

Go into user prefs.
Go to input.
Search for ‘rotate’
Under 3d view turn off the two actions linked to ‘trackpad’
Search for ‘zoom’.
Under 3d view you will see an action linked to ‘trackpad pan’
Expand this and uncheck crtl

Ta da!

I can see why this new setup could be useful, but not when you have your mouse set up a certain way. Oh well, it’s fixed now. I hope this helps anyone experiencing the same problem.

i cant uncheck ctrl.
it asks me to press any key. There is a key for the mmb ( alt + lmb ) but what if i want it to zoom by scrolling?

Please help. Thank You

There is a small arrow on the left hand side of the list, this will expand the action properties. In this extended section you can uncheck ctl
. hope this helps.

Thanks a lot ! It’s work well !

Ok, found a problem with my fix.

I can no longer choose the number of loop cuts after hitting Ctl-R using the magic mouse. can’t find this in the prefs at all. Don’t really want to resort to using - and +.

Anyone know how to fix this?

same problem here… maybe they will release a 2.66a with a fix…

EDIT: even setting it back to factory settings didn’t solve the problem… 2.65 works fine

My Logitech M505 (normal 3 button mouse) works fine. in my opinion, it has nothing to do with the user preferences. i think, blender doesn’t recognizes the magic mouse as a mouse anymore.

Tried with an early testbuild of 2.66 (2.65.xx) and they’re not working either with the magic mouse.

I may be wrong but i fear that this may be a ‘fix’ already.

Quote from the dev page:
“Laptop trackpad (and Magic Mouse) now supports zoom with hold ctrl too.”

The magic mouse is quite useless unless you use a third party program to enable a middle mouse button. I had mine set up perfectly using ‘BetterTouch Tools’. but no more…

Here’s hoping there is a way to use the old system soon.

I’m not happy with the change either. I can see that there always were difficulties with the Apple trackpad and magic mouse, but in case only one can work fine, I would prefer the magic mouse. Changing shortcuts back works for zooming in 3d, but not being able to increase brush size and loop cuts by scrolling is a huge step back.

Does anyone know if this new behaviour was planned or is just a bug.

There was a bug report about the matter, closed now, related to another aged bug (#28092), closed too… everybody is satisfied, I can’t even figure how.

Look at it:


The bindings that Blender have are not right and conflicts with OS X 10.7.

Magic mouse functionality has disappeared for me also. In OS X 10.7, Holding CTRL while swiping trackpad or mouse is already a binding, which zooms the entire screen. As far as I know there is a user setting to change this in OS X, but turning it off would turn it off for everything, so a poor solution.

Blender treats the magic mouse like a track pad, but also binds CTRL-zweep to zoom function !!! Wow, guys!
I’m also experiencing problems with other tasks in blender that required the track functionality of the magic mouse or Apple trackpad - like edge loops or brush settings.

So, unless I missed something, then this is a bug in Blender 2.66 that should be filed after all.

However, I’m afraid, looking at the discussion of issue #28092, then Ton Roosendaal et al will consider this closed so bug reports on it will be erased without even being read.

If you ask me, then someone who has direct access to Ton should bring up the issue with him directly.

This very same issue is arising in several threads, so I hope something will be done soon or later.