Movie texture animations now possible?

Okay, this is less about materials and textures, more about the recently-exposed ability to animate movie textures in Eevee.

I have been scrubbing the video footage found here in order to learn what the node setup they used was, even though you could see it throughout the video.

I have mimicked this node setup to no avail. They are using .MOV and .MKV, I am using .FLV, if that means anything. I learned it still does not animate when I hit the play button, but it animates when I scrub with the preview open, which fails when the preview is closed. I have given it a large amount of frames to work with, over 20000.

May I please ask if there is anything I am missing?

There was a possibly related fix yesterday morning, so if you haven’t already downloaded the latest 2.80 today then try today’s build and see if that makes any difference.

I will wait for another build. The build the guys in the video used was dated February 18th. The latest I downloaded, at the time, was February 19th. I will wait for the builds to update again before trying again, then I will let you know what happens. Thanks.

You don’t need to wait. The fix is in the current 2.80 downloads at:

I think you got the previous night’s build which did not yet have the fix in it.

7 hours later:
I just checked today’s build (Labeled 2/20/2019), I am still not getting it to work. This means something I am doing on my own end is incorrect, I am going to continue searching for answers.

Edit to prevent multi-posting, 16 hours later:
In the recentlyhash-edited build of 2/20/2019, if you move the frame indicator then check and uncheck either “Cyclic” or "Auto-Refresh, the frame visible on the movie texture will match it, but it still will not animate, from what I have currently determined, though this could all be just me.

Edit 2, the following day:
I recorded this video in an attempt to display what happens when I attempt to add in an animated movie texture. The file I am using is .FLV, if that matters. Maybe specific file extensions fail, in some ways. I am running out of ideas here.

Ok, if I go through your steps I get exactly the same behavior here.

I tried a random mp4 file with the same result.

However, once I save the file and then re-open the saved file, it works!

1 Like

…Oh, my servers. I never would have thought of this! It works!!! It totally works now! Thank you, so much!!!

Cool. I’ve entered a bug.

I am going to alert everyone in the comments section of the 2/18/2019 Blender Today video, since I ran into a few people down there who were experiencing similar problems. Thank you so much, this is a massive relief!

1 Like

Aaaaand it’s fixed! Should be in tomorrow’s build.


I just checked! Yes! It works without needing to save the file now! Thank you, blender devs! Also, thank you, Pixelfox, for reporting the issue to begin with!!!

1 Like