Moving along path?


(s_m) #1

Hi everybody!

Help needed:
I tried to reproduce something like in this tut:
http://vrotvrot.com/xoom/tutorials/Welder/Welder.html

but more complex, so I have box as a particle emitter parented to a closed path with ‘CurvePath’ and even ‘CurveFollow’ buttons, I can control box’s speed and timing with ‘PathLen’ (or Time IPO), but:

  1. Box start movement not in the point I want (in the point where dushed ‘parrenting’ line connects with the curve). I solved this with ‘PathDist Offs’ button for curve and ‘TimeOffset:**’ for box.
    Is there another solution for this situation?

  2. Particles starts anyway from box-parenting initial position and not from ‘TimeOffset:**’ position. I can’t find solution for this (I already tried ‘Offs Particle’, Alt+P, Alt+G).

Could somebody help me?

Sorry for my english.


(j) #2

Move the box in frame one to the place where the path starts.
Hopefully a simple thing like that will do it.


(s_m) #3

Thanks for your reply.
Unfortunately, not so simple.
If I move the box to any position in the space, it will start moving from that position and particles will have risonable offset, but box and particles will start copy the path configuration NOT from the desired position on the path and it will be just like the same problem in another position!

Could anybody else know?


(s_m) #4

My .blend file: CurvePathTest.blend (100 Kb) if it could help.

Press Alt+A to see what I’m talking about.


(Fligh) #5

Get rid of the offset and rotate your CurveCircle so the start position (where the dashed, parent line points to) is where you want the emitter mesh to start from. Reshape it and in F7 RecalcAll on the emitter mesh.

http://blender.isoserv.com/uploads/CurvePathTest2.blend

%<


(s_m) #6

Thank you, Fligh %!

It’s a possible solution with a simple path like that in my attached file, but it’s not so simple with imported compound path like compound logos (elysiun full-word logo for example).

May be graceful solution will be found someday…

Thank you any way.


(s_m) #7

I solved the problem using OPEN path, but another problem is that flight path is not exact:

http://img287.imageshack.us/img287/6959/partmove7le.th.jpg

.blend (108 Kb)
Press Alt+A to see


(vliegtuig) #8

How funny.
I’m using 2.40 a2 and 2.37a but none of them can tell me where to find the ‘curvepath’ button.
I can find the curveFollow constraint but I’m sure that’s not it.
Anybody know how that could happen?
P

EDIT: Never mind. Had to be a curve first.