moving objects layer to layer

I searched the forum and I read the online community documentation, but I can’t figure out how to move objects from one layer to another. I tried doing this in OOPS! but couldn’t figure it out, even with docs :frowning: any suggestions?

Do you mean just move the object from one layer to the other while modeling, or keyframe the movement of an object to another layer to use in an animation???

The former is easily done if you select the object, press the ‘M’ button … you get a pop up menu with little “boxes”, that represent all the available layers… Click with your mouse on the “destination” layer and click “OK”… Voila the object is moved to another layer…

If you want to keyframe that, put your cursor on the 3D view window and press “I”, from your keyboard… From the menu you get, click with your mouse on ‘Layer’… Proceed to the next frame with the arrow keys (‘UP’ arrow takes you 10 frames forward at a time, ‘LEFT’ arrow takes you 1 frame at a time…), until you get to the desired frame… Then move your object to the desired layer (as described above…)and press ‘I’ for one more time… Choose ‘Layer’ again and Voilla!!! Press ‘ALT+A’ on the 3DView window or render the animation, to see the effect…

I hope I’ve covered your question…

yuppers, you answered my question. I’ve seen the layers dialog with the M-key before, but I thought it was just a way to change layers, not move from layer to layer. Thanks for the response :smiley:

You can also check and move object into layers with the object draw tab (F7 on Blender 2.31).


Okay. For whatever reason, this trick is not working with me.

I’ve got three planes, and I’m trying to swap them from one layer to another, the plane I WANT to see appearing on one layer.

Let me back up. I’ve already done a bunch of animation, and now I’m just trying to duplicate one plane into three to do all this swapping.

Or, no, I duped it awhile back, ONCE, and now I’ve duped it again to continue with my animation.


The new duplication follows it’s “creator” from layer to layer. I’m losing my mind. I’ve tried moving the unneeded one to the new layer, and then selecting everything else on that layer and I-Layer. And then swapping to the “hider” layer, selecting all and I-Layer again - because, in doing this maneuver on another article, I discovered that if I just moved the item to a different layer and then clicked “I-Layer”, it didn’t work.

Am I just way off?

And, now, how in the world do I clear all these Inserted Layer changes?

It follows its creator because you duplicated it in edit mode.

Get rid of the layer changes in the IPO window by selecting all and delete with X.

If I duped it in EDIT mode, then why are there two objects in OBJECT mode? If it was duped in edit mode, then, wouldn’t it be a single object? As it is now, I can move one to a different layer and the other will stay on the current layer, UNTIL I switch frames, at which point, the second one follows the first one.

Where? Which drop down? I’ve looked in all of them, and don’t see any of my changes showing up (well - there’s no vertexes to indicate the changes.)

Well, you only get as good as you give, lol. Your explaination wasn’t very coherent.

Yes, if you duplicate in edit mode the two will be one object, so, if they are two seperate objects make sure that they are seperated (not instanced). Shft-D makes a seperate copy with with seperate data and Alt-D makes an instanced copy with shared data. Seperate with ‘P’ in edit mode.

Also when you I-Key your layer change you could also be I-Keying your visable layers, so even though the IPO’s for the objects are correct the IPO’s for the visable layers make the objects visable/invisable or somesuch.

To delete Layer IPO’s RMB either the IPO Data Block (blue square next to the word ‘Layer’ in the IPO window, or RMB (Shft-RMB for more than one) the curves themselves to select them (knots turn white), hit X and choose ‘Erase Selected’.