MultiEdit version 1.0: Multiple Objects Editing

I’ve been playing with a newly tweaked version of alpha 4 and it’s looking good! All position, rotation, scale and modifiers seemed to be preserved! The only bug I’m encountering now is that objects that have their material assigned to the “object” instead of “object data” lose their material assignment when coming out of multiedit mode. Interestingly, it seems that object material assignments that are set to “object” are getting changed to “object data” by the script. No errors are getting produced though so that’s awesome!

I did some further poking, trying to break things. I went into multiedit mode and started selecting faces and changing material assignments. When I exited multiedit mode, the original material assignments were restored, and I lost my new material assignments.

Poked around further and tried bridging meshes together in multiedit. When I exited multiedit, the script separated the new joined mesh into the 2 original meshes, plus a new mesh for the new geometry that I created. I also lost the scale values on the original meshes involved in the bridging operation. In all honesty, I’m ok with this, since I was technically creating a new mesh by combining 2 meshes together and the script still managed to deal with this in a pretty elegant way without producing errors.

All in all, this is turning into a really kick ass solution to edit multiple objects together in blender! I hope this new verison gets posted up here (or antoni4040 gives me permission to post it) so everyone else can battle test it too!

Patience is the key to success…
The add-on still has some problems and limitations I would like to tackle before I publish the next version officially…
Here’s a version with all the new features. I would suggest not to do any serious work with it just yet.

If you want to help me perfect this add-on, you can test it, give ideas, code fixes or a donation through my blog:

Right in time!!!

Great addon, thanks!

There is a problem with 0.4.
When I Exit, the meshes does not have the same name than before.
I need to keep the same name.

I guess I’ll have to check that out. Does that always happen, or only in one file?

Hey people, some strange stuff happening with Blender 2.73a, could you check if this works for your projects:

Thanks everyone!
EDIT: here’s the GitHub page, as some of you requested:

It’s finally stable and working for me, you might want to check it out…
Links in the post above!

Thank you antoni works great! you don’t know how much easier you made my life :slight_smile: I am exactly uv unwrapping multiple object on to the same uv and before when I need to fix something I need to join the objects together and lose the naming everytime when I did notice something was wrong with the uvs. But now I can just go into multi edit mode, such a huge time saver. Thank you again :slight_smile:

No problem! So, everything is all right now? If you encounter any problems just tell me… I’m in programming mood these days! :wink:

This is a really neat add-on! Liking it for the same reason phelioz above does.

You need to make a demo video of this being used for texture painting. It’s not obvious that this is possible from other videos, and this aspect is really useful. (The process of painting stuff with shared UVs/Textures like that from Texture Atlas add-on can be a royal PITA otherwise. Saves having to merge objects just to paint across multiple parts.)

Only found that out because somebody pointed it out to me, even though I heard about this add-on before and watched one of the videos. (But none of them showed anything with texture painting, so I didn’t assume it was covered.)

Yeah I have actually not encountered a single problem yet, so again thank you

Thank you! A new video is on it’s way. The only problem is that I’m a total texturing noob, and never knew while I was creating it that it would be useful for texturing as well. :stuck_out_tongue: I was focused on modelling, the part that I like the most… But I’ll figure it out!

I’m not exactly the worlds best at texturing either. But it’s great when you have something like a vehicle with doors and various body panels which are separate objects and you can paint straight across everything. Without this plugin it involves selecting, painting a bit, selecting, etc. I’m sure you could imagine how hard that makes it to evenly carry a line across in the body art without it.

I don’t do much character art, but I suppose this would also be useful for painting multiple articles of clothing or whatever at the same time too. I could see where that would make coordinating stuff easier when you can do it on the fly.

Only thing I haven’t tried is texture painting across things with different UV and texture maps. (Stuff I’ve used so far all has all parts sharing a common map.) I don’t see why it wouldn’t work though.

I wonder how stable it’ll have to get before it’s on the list of included plugins? It should be in there, because its that useful.

antoni4040, I’ve got some bugs with the addon.

I’ve been using it in production, in a real life situation. Unfortunately don’t have much time to go through explaining it. Hopefully during the weekend I get a breather and drop you a sample file with some info.

Does it keep uv maps?

It does, from what tests I had done.

Here are some of the issues I have tracked down.

  • If the scale is not applied - this will skew the object
  • Vertex Groups create an issue. On my end, objects with vertex groups are separated (so it’s 2 meshes now)
  • Parenting is not preserved

Here’s a file you can test all of this to confirm.

  • just enter and exit multiEdit with all objects selected

If you Clear Parent, you will get something different.

…I don’t know how you’re dealing with all this on the scripting level, thought I’d throw an idea out there:

  • Duplicate selected objects
  • Merge, enter multiEdit
  • … Do you scripting magic :slight_smile:
  • On Exiting multiEdit, each of the meshes that you already have mapped as a ‘unique’ object:Find the Source Object, enter Edit, Select All, Delte All. Now Merge the multiEdit Object with this one. This would at least preserve the Parenting and Modifiers. Scale, Transforms and Pivot Point. All in one go.

Hope it helps

Hmmm… Also seems to have some problem with either local view and/or using hidden meshes while in multi-edit. Seems to lose track of naming or splitting things apart into new meshes if you exit multi-edit mode before un-hiding stuff or having everything in view. Probably simple to fix by running a check making sure everything is visible and in scene view before doing what it does when exiting. (I’m guessing blender temporarily treats stuff not viewed as separate?)

If it helps any, I get this in the hidden console thingy:

Traceback (most recent call last):
  File "C:\Documents and Settings\Paul\Application Data\Blender Foundation\Blender\2.72\scripts\addons\", line 225, in execute
    self.Fix_Objects(active_object, name, vgroup_index)
  File "C:\Documents and Settings\Paul\Application Data\Blender Foundation\Blender\2.72\scripts\addons\", line 291, in Fix_Objects
    wanted_object_name = duplicated_list[(name_list.index(]
ValueError: 'rear_fender.001' is not in list

location: <unknown location>:-1

Sorry guys, I was kind of busy… :stuck_out_tongue:
I’ll check out all the problems during the week(probably…).
I hope you find it useful even if it has a few problems! :slight_smile:

I apologize if I’m doing this wrong but this is my fist post on the forum and I’m also kinda new to Blender. So please don’t be too harsh to a noob :stuck_out_tongue:

I’ve used this addon already on other models and it was working perfectly fine (seriously I love it), but on my last project I had an issue that totally messed up my geometries and, as a consequence the rig.
I read this thread looking for an answer but the updates are not really helping me. Basically I started using the MultiEdit in order to fix UVs on the UVmap, but now I’m stuck in the MultiEdit mode and if I exit all the objects are merged in weird ways that create new geometries.
On this thread there’s people saying they had the same problem but also that it was fixed after the 0.4 version. Am I doing something wrong or is this part of the bugs you were looking into? Any hope for at least going back to my original model? I can provide the blend file if you need it.
Btw keep up with the good job; this addon really helped me to get into blender the fast way!