Multiple addons using the same name (error)


(Chelle) #1

Hi,

I just installed the Blender 2.59 on my mac. And wanted to install the ‘Twisted Torus’ add-on that I had been using in my previous version. After adding it I could not activate the checkbox, so I took a look at the reference page of that plug (link) and read a note that it was merged into the ‘Add Mesh: Extra Objects’ plug (link) so I tried to install that one but got a ‘Multiple add-ons using the same name’ error (see pic below)

Now I can’t get rid of this error. I 've thrown my Blender-map out and tried to use a new freshly expanded Blender-package but get the same error.

thanks in advance for any help to get this fixed,

greetings,

m.

http://img819.imageshack.us/img819/4709/addone.png


(test-dr) #2

check the console-output messages about the name of the addons.

If you dont know how to view those, start blender out of a terminal and
dont run it in fullscreen so you still can view the output error messages there.

There are different places for installed addons. Depends on the operating-system used.
In Linux its in the installed blender directory and in the users-home-directory .blender.
Next - inside the blender directory, you may need to search the duplicate entries,
i used “grep” to search for the named addon-class,
if it fails for you to identify the files with the same addon-names, the only way
is to completly delete the installed blender. To do a new install might fail, because
it may only overwrite existing files and not delete additional installed ones.

edit: the hint about changed “script-path” is only the reason, if you did some own changes inside the py-files.


(Chelle) #3

Thanks test-dr,

I’m not very familiar with using the console … so i just got the idea to look for an uninstall program for Blender, as some programs provide it. I didn’t find one, but I found one for OSX (AppZapper) which took care of the job. Turns out that I overlooked a Blender map in my ‘Library’ under ‘Application Support’ called ‘scripts’ (see pic). I’ve deleted them all and the error message is now gone.

grtz,

m.

http://img202.imageshack.us/img202/6295/applicationsupport.png