Multiple Alpha Layers on material

Ok, my blend file is here if it helps:

Basically, I’m creatng an armor, which uses material nodes to layer decals on top of a base metal material. It was mostly working fine, until I tried to add more than one decal. Putting two alpha textures in a decal material doesn’t seem to work right.

in the .blend, look at the material called “Breastplate - detail”
It has a texture layer called “breastplate” which is the main design on the front. That works fine. What I’m trrying to do now, is add a second texture layer, called “upper stripe” which is intended to be a horizontal stripe across the top of the baked texture.

My problem though, is that the “upper stripe” layer simply doesn’t show in the render. It’s not showing in the material preview either. I suspect thealpha from the other decal texture is blanking it out somehow.

My first thought then, was to enable the alpha option in the Map To panel, for that texture layer. But that just makes the entire material fully transparent… I’m a bit lost now, and not sure how to make it work. Worth noting though, is that each of the alpha textures is done differently.

The main design I drew in photoshop. It’s a 32-bit .tga with an alpha channel. The stripe, is jsut a solid block of color, using the “Clip” option in the textures panel, and stretched to fit across the desired area. It’s in .png format if that’s relevant.

Is there any way to make my textures work properly together as I want? Do I have to modify the images themselves? or put them on different materials perhaps? Having them on a single material would be ideal, but not necessary, I suppose.

real quick, without looking at ur file, you probably need to change your layering mix mode from mix to like add.

Changing the layering mix mode on both decal textures to “add” has no apparent effect. Other suggestions?

Does anyone have an answer on this? I’m really stuck :frowning:

ok, Answer no longer needed here. I sorted the problem

turns out I had one of the decals set to Orco mapping mode, where it should have been UV.