Multiple Layering in Blender... Noobie question!!

Okay guys, so I am following a tutorial and I am doing some basic compositing. I am trying to composite the lights, and I moved it to separate layer to do so. Problem is, every time I render in that separate layer, it either renders only the lights, or the rest of my render. It is driving me crazy, but I can’t figure out how to put BOTH layers into one render! This is probably a stupid newbie question, so hopefully a one sentence answer will suffice, my palm will hit my forehead, and I can go on with my tutorial :P. anyone have any advice?

Do you have your render layers connected with a mix or alpha over or a z combine node? I mean, do you have the two layers mixed or overlayed with one of these nodes I mentioned?

Yes, I have the layers in a “Mix” node. When I do it in the first layer, it just doesn’t show the lights, and if I select the second layer, it renders just the lights. The other weird thing about that is that I can see the rest of it rendering and then turning black. I will go double check to make sure that I am mixing it right.

Yeah, so I have it set up in the compositor for a mix, I can even see it on the viewer, but when I hit mix the lights don’t add to the original scene. Am I missing something here?

Okay, to make it easier to spot whatever problem there is, I have posted the picture of the composited image with my little nodes. Note that the image in the background does not have any lighting fixtures, which I want. Any help would be appreciated!

Edit: I just realized that it IS showing up, but really faintly. Is there any way to make it actually show up, and less transparent?


Up the factor of the mix, I see you have it set for add, I guess it is about setting the mix factor higher… but realize, you can duplicate the original light render layer and add it in again on top of that.

Yeah, thanks! I guess that was all that I needed, it worked! The reason I was hesitant to do that, was because for some reason the light blur effect didn’t show up as prominently as I wanted. But thanks for helping me, I got it! Problem Solved!